PDA

Visualizza versione completa : Accesso negato alla cartella C:\Document and Setting\All Users\Documenti


redbellerofonte
22-10-2005, 20.27.04
Salve a tutti!
Sul mio portatile ho installato WinXP Home Edition. Funzionava tutto alla grande fino a qualche tempo fà ma ultimamente quando vado ad accedere alla cartella C:\Document and Setting\All Users\Documenti mi appare una finestra di avviso che mi impedisce di entrare negandomi l'accesso.
A cosa può essere dovuto questo malfunzionamento?
Grazie a tutti!!!

Thor
22-10-2005, 20.38.26
hai smanettato coi permessi? accedi come amministratore?

redbellerofonte
22-10-2005, 20.43.41
Se non mi sbaglio con WinXP Home Edition non � possibile evere restrizioni sui permessi di accesso alle cartelle o perlomeno o cercato tra le propriet� della cartella ma non li ho trovati.
Tra la propriet� della cartella non ho trovato alcuna voce che mi abbia permesso di accedere alla cartella.

massimino
22-10-2005, 22.23.10
Se non hai la scheda PROTEZIONE (se hai XP su NTFS) devi entrare in opzioni cartella--visualizzazione--togliere il segno a: Utilizza condivisione file semplice, poi clicca destro sulla cartella--propietà--protezione--avanzate--propietario--metti il segno a: Sostituisci il proprietario in sottocontenitori ed oggetti--OK
Se invede hai FAT32 non saprei

Dav82
22-10-2005, 22.27.00
Originariamente inviato da massimino
Se non hai la scheda PROTEZIONE (se hai XP su NTFS) devi entrare in opzioni cartella--visualizzazione--togliere il segno a: Utilizza condivisione file semplice...

Con XP Home è possibile usare solamente la condivisione file semplice ;)

Anche se in effetti, ho letto in giro che si può utilizzare il comando calcs per impostare i permessi dell'utente su una determinata cartella in sharing...

massimino
22-10-2005, 22.50.36
AH, HOME! Chiedo scusa. Allora in modalità provvisoria con rete :)

redbellerofonte
23-10-2005, 01.41.20
e come funzionerebbe questo misterioso (per me) comendo calcs per modificare i premessi di accesso su una cartella?
Grazie

Thor
23-10-2005, 11.23.28
non è calcs bensì CACLS ;)

prompt dos, e scrivi cacls /? per le istruzioni.

segui anche questi link:
http://www.ss64.com/nt/cacls.html
http://www.web-hosting.com/support_old/nt/permissions.html
http://seriss.com/rush-current/rush/rush-howto-configure.html#FixWindowsDirectoryPermissions

Thor
23-10-2005, 11.25.54
Ci sono poi altri tools per le permissions:

1) FILEACL.exe - NTFS Permissions command line tool
http://www.microsoft.com/downloads/details.aspx?FamilyID=723f64ea-34f0-4e6d-9a72-004d35de4e64&DisplayLang=en


2) XCacls (Extended Change Access Control List Tool)
http://www.microsoft.com/downloads/details.aspx?familyid=0ad33a24-0616-473c-b103-c35bc2820bda&displaylang=en


3) SetACL.exe (freeware)
http://setacl.sourceforge.net/

redbellerofonte
23-10-2005, 11.57.01
Ho provato a lanciare dalla linea di comendo dos la seguente istruzione:
cacls c:\Documents and Settings\All Users\Documenti /E /G Sandro:F ma non cambia assolutamente nulla. :confused:

massimino
23-10-2005, 12.57.12
Ma potresti partire in modalità provvisoria con rete come avevo detto (tasto F8 o F5 in avvio), cosi entri nelle rpopietà -- protezione della cartella :)

redbellerofonte
23-10-2005, 13.29.46
Mitico!!! :D Funziona alla grande!!!!! Sono entrato in modalità provvisoria con rete ed ho smanettato un poco con le autorizzazioni e tutto funziona alla grande!!! Grazie 100000000