PDA

Visualizza versione completa : EXCEL funzione Cerca Vert


astro91
22-02-2005, 16.31.10
I risultati della funzione Cerca Vert possono essere due:
1) mi restituisce il valore che ha trovato
2) mi restituisce #N/D in quanto non ha trovato nessun valore
In questo secondo caso sono costretto a cancellare manualmente tutti gli #N/D altrimenti nelle formule mi dà errore.
Esiste un metodo veloce per cancellarli o convertirli in zero?
Ho provato con Modifica/Sostituisci ma non funziona.
Grazie.

Cricchia
22-02-2005, 16.37.20
Devi scrivere così:

=SE(VAL.ERRORE(CERCA.VERT(B1;A:A;1;0));0;CERCA.VER T(B1;A:A;1;0))

;)

astro91
22-02-2005, 17.04.46
Grazie, funziona xfettamente.

Cricchia
22-02-2005, 17.06.16
Originariamente inviato da astro91
Grazie, funziona xfettamente.

;) prego!

astro91
22-02-2005, 18.02.34
Visto che sei così bravo, provo a sfruttarti ancora.
Dunque, seguemi che non è semplice.
Ho degli elenchi, ciascuno dei quali contiene come record dei cliente con il loro fatturato, e ho un elenco per ciascun mese.
I clienti non sono sempre gli stessi.
Vorrei crearne uno unico ricapitolativo dove mi somma per ogni cliente il fatturato che trova su ogni mese che può esseerci come no.
Quale funzione posso usare? Sono stato chiaro?

Cricchia
22-02-2005, 18.08.07
Iniziamo col dire "bravA" ;)

Cmq, per fare quello che vuoi tu, puoi crearti una tabella pivot, inserendo in riga la colonna cliente e trascinando il fatturato nella tabella, poi usi la funzione somma..

E' difficilino da spiegare, ma se posti il file (non con dati veri naturalmente) posso darti una mano!

astro91
22-02-2005, 18.29.13
Come faccio a postarti un file excel con + fogli?

Cricchia
22-02-2005, 20.33.48
Originariamente inviato da astro91
Come faccio a postarti un file excel con + fogli?

hai un pvt ;)

astro91
23-02-2005, 07.42.29
E che cos'è?

Cricchia
23-02-2005, 09.29.51
un messaggio privato!!! :)

il_gian
23-03-2006, 19.09.43
Posso aggiungere una piccola domanda su questa formula?

E' possibile non definire la matrice di ricerca "all'interno della fromula" ma fare in modo che la formula capisca dove andare a cercare prendendo la definizione di matrice da una cella esterna?

Provo a spiegarmi meglio: ho centinaia di celle con una formula Cerca.vert che devono cercare i valori in un altro foglio excel. Il problema è che la matrice in cui cercare i valori può cambiare.
Quindi vorrei modificare la matrice dentro le celle in un colpo solo, senza dover modificare tutte le formule.......

Qualcuno mi aiuta?
Ho provato a mettere dentro la formula, al posto della matrice un indirizzo di cella in cui ho messo la matrice (e che vorrei modificare a piacimento).
LA cella è formattata come "testo".
La formula, però mi da errore.
Come faccio??

Cricchia
23-03-2006, 23.09.58
mmm... potresti definire la tua matrice con un nome e successivamente, quando devi cambiare la matrice, ridefinire il nome.

Es.

1) la tua matrice ora è a1:c3
2) definisci questo intervallo con il nome "prova_matrice" (da menù Inserisci => Nome => Definisci oppure scrivi "prova_matrice" direttamente nel campo "Casella nome")
3) imposti i cerca.vert così (metto a caso gli altri parametri): =cerca.vert(a1;prova_matice;2;0)
4) se poi, devi cambiare la matrice, non fai altro che ridefinire il nome "prova_matrice" (vedi punto 2)

però, ad essere sincera, non sono sicura di aver capito! :p

il_gian
24-03-2006, 17.56.57
Ciao Cricchia.
Grazie per la tua preziosa e rapida risposta.
Credo che tu abbia risolto il mio problema, ma per sicurezza mi spiego meglio.
Ogni giorno ottengo un file contenente i dati delle vendite della mia zona, in cui ci sono una ventina di clienti. Invece di fare 20 file diversi, ne faccio uno contenente tutti i clienti in verticale.
Semplifico dicendoti che ogni cliente "pesa" 100 righe nel file di excel, quindi:

Cliente 1 = da riga 1 a riga 100
Cliente 2 = da riga 101 a riga 200
Cliente 3 = da riga 201 a riga 300
.............
e così via.

In un altro file, cerco di riordinare queste informazioni con un foglio globale e tanti fogli quanti sono i clienti in cui ci sono tante formule cerca.vert che vanno a pescare i dati dal file generale.
Il problema sorge nei fogli relativi ai clienti: al momento la formula funziona bene perchè la tabella_matrice del cerca_vert non cambia, quindi tutto fila liscio.
Se per caso, un cliente dovesse occupare una riga in più o in meno, le tabella_matrice dei vari fogli dei clienti sarebbero "sballate", costringendomi a modificarle tutte con un mega "trova & sostituisci".

La mia idea era quella di definire in una cella la tabella_matrice del cerca.vert (per esempio la cella A1) e fare in modo che ogni cerca.vert puntasse su quella cella per capire dove andare a cercare i dati:

in A1 ho scritto:
'[indirizzo del file + nomedelfile]foglio'!area

e le formule dovevano essere
=CERCA.VERT(dato;A1;colonna,FALSO)

Peccato che non funziona. Ottengo un errore #N/D. Ho provato a verificare che la cella fosse formattata come testo, ma non è stato sufficiente.Magari l'errore è minimo, o magari no.


La tua soluzione mi dice di "battezzare" la tabella_matrice con un nome, così da inserire questo nome nella formula. Credo che possa funzionare: provo tra poco e ti faccio sapere.
Per curiosità, vorrei sapere se la mia idea era una grossa fesseria o no....

Fammi sapere.
Grazie ancora per il tempo che mi hai dedicato.

il_gian
24-03-2006, 19.32.49
Ho battezzato l'area, ma la formula non funziona.
Sarà perchè si trova in un altro file???

xelav
10-04-2006, 22.53.42
Potrebbe esserti utile la funzione =indiretto guarda la guida