PDA

Visualizza versione completa : JVM Problemi e Dubbi


Pandax
13-05-2004, 10.15.51
Ho installo Win Xp Pro + SP1a

poi sono andato a installarmi la JVM di Sun

scaricata da qui http://www.java.com/en/index.jsp

ma a quanto pare non funziona come dovrebbe, alcuni siti nemmeno li apre.

ho controllato sia in IE->Strumenti->Opzioni->Avanzate ed è selezionata la JVM di Sun

ho controllato Impostazioni Accesso ai Programmi ed è selezionata la voce "Utilizzo JVM corrente" ... nessun altra opzione.

io credo a sto punto che sia solo che alcuni siti vanno con la JVM di Microsoft... forse perchè per un periodo era disponibile questa... e sono stati ottimizzati per quella della Microsoft.

Cmq...

adesso pensavo di disinstallare la JVM di Sun... e installare una versione di quella della Microsoft

domanda:

so che esistono diverse versioni... io sono andato su questo sito ad esempio http://home.wanadoo.nl/jheroen/VM/downloads.htm

quale devo installare?
mi sembrava di aver sentito che la Build 5.00.3810 fosse solo un aggiornamento delle vers. precedenti.

Devo quindi installare una vers. precedente e poi la Build 5.00.3810?

O installo direttamente la Build 5.00.3810 (che intanto è l'ultima vers.) ?

Altri consigli?

Grazie a tutti.

Flying Luka
13-05-2004, 10.20.33
Io continuo a tenere la JVM prodotta e distribuita dalla SUN.
E, via via, sostituisco la versione con quella più recente.
Ho notato anche io che alcuni siti fanni fatica a "girare", ma cmq NON rimetterei mai la vecchia JVM distribuita da Microsoft in quanto è pittosto obsoleta e piena di bug.

http://www.java.com/en/download/windows_automatic.jsp

Pandax
13-05-2004, 10.24.25
io terrei anche quella della Sun... ma se non mi fa aprire alcuni siti che uso... non andiamo molto daccordo.

p.s. ovviamente la vers. della JVM di Sun che ho installato è l'ultima. scaricata appunto dal link che mi hai segnalato tu.

Flying Luka
13-05-2004, 10.31.30
Originariamente inviato da Pandax
io terrei anche quella della Sun... ma se non mi fa aprire alcuni siti che uso... non andiamo molto daccordo.

p.s. ovviamente la vers. della JVM di Sun che ho installato è l'ultima. scaricata appunto dal link che mi hai segnalato tu.

sono d'accordo... la JVM di SUN non va d'accordo con alcuni siti, ma credo sia un piccolo prezzo da pagare per la sicurezza.
Ad ogni modo ho letto che la Microsoft pare stia sviluppando una specie di java (che ovviamente non si chiamerà così) da implementare nei propri sistemi operatrivi....
E la guerra Microsoft/Sun continua...

Ad ogni modo ho notato che, per alcuni siti ostici, se svuoti periodicamente e regolarmente la cache, c'è un piccolo miglioramento!

Pandax
13-05-2004, 11.01.34
i problemi rimangono... e io non so che fare...

qualcuno sa rispondermi su quale JVM di Microsoft tentare di installare...

magari potrei... formattare e mettere il SP1, invece del SP1a.

ho sentito dire che nel SP1 è già dentro la JVM. Quindi non avrei il problema di installarla.

Che mi sapete dire su questo?

E sulla vers?

Grazie a tutti.

ps in caso...qualcuno sa da dove posso scaricare il SP1 ? ciao ciao

Flying Luka
13-05-2004, 11.14.55
Se proprio vuoi la JAVA obsoleta di Microsoft, la trovi qui:

https://www.alibre.com/alibrelibraries/ftp/JavaVM/9xNT4/msjavx86.exe

Ti faccio i miei migliori auguri... buona fortuna! :D


P.S. computer con la Java Virtual Machine di Microsoft sembrano essere in pericolo. Secondo quanto dichiarato dalla stessa Microsoft, che ne ha dato notizia soltanto dopo aver trovato un rimedio al problema, le vulnerabilità del sistema sarebbero addirittura 8 e tutte permetterebbero a pirati senza scrupoli di prendere il controllo del computer a distanza.

Microsoft sostiene addirittura che questi “problemi” di sicurezza potrebbero riguardare gran parte dei computer con installato Windows. Per evitare panico è comunque bene dire che la versione della JVM incriminata è la 5.0.3805

Pandax
13-05-2004, 12.06.34
ho scaricato la tua vers di JVM di Microsoft... è la Ver 3809 e da quel che vedo non è un sec fix update per la 3805.

Come invece c'era sul sito che ho segnalato prima.

Che dici, se provo a installare questa tua Vers. + il sec fix update 3810 del sito che ho segnalato prima?

Ciao ciao..

Flying Luka
13-05-2004, 12.57.35
prova... ma non penso che migliorerà l'incompatibilità con alcuni siti...

The Saint
15-05-2004, 14.32.27
Originariamente inviato da Pandax
ho scaricato la tua vers di JVM di Microsoft... è la Ver 3809 e da quel che vedo non è un sec fix update per la 3805.

Come invece c'era sul sito che ho segnalato prima.

Che dici, se provo a installare questa tua Vers. + il sec fix update 3810 del sito che ho segnalato prima?

Ciao ciao.. Prima di installare, vai su Start -> Esegui e digita "jview", così controlli la versione della JVM MS installata (quando installi la Java di Sun quella MS non viene disinstallata).

Pandax
16-05-2004, 15.28.35
jview funziona solo se installa la virtual di microsoft vero..?

cmq...

domande:

- andando su www.aruba.it vi escono anche a voi finestrelle di avviso errori vari javascript?

- e su www.lycos it ... qualcuno di voi usa la chat? io non riesco nemmeno a visualizzare la pagina di login..


credo dipenda dalla virtual machine.. e non so proprio + che fare..

The Saint
16-05-2004, 16.10.49
Originariamente inviato da Pandax
jview funziona solo se installa la virtual di microsoft vero..?

cmq...

domande:

- andando su www.aruba.it vi escono anche a voi finestrelle di avviso errori vari javascript?

- e su www.lycos it ... qualcuno di voi usa la chat? io non riesco nemmeno a visualizzare la pagina di login..


credo dipenda dalla virtual machine.. e non so proprio + che fare.. Sì, jview funziona solo se è installata la VM di Microsoft... mi sono accorto ora che se lo lanci da Start -> Esegui la finestra si chiude subito... bisogna lanciarlo dal Prompt dei comandi.

Su Aruba nessun problema (io uso la java di Sun), su Lycos anche nessun problema, non ho provato xò a fare il login dato che non sono iscritto...

Pandax
16-05-2004, 16.35.34
ma.. riesci a visualizzare la pagina chat.lycos.it ???

guarda a me cosa visualizza! non riesco proprio a capire...

The Saint
16-05-2004, 18.53.50
Anche a me viene visualizzato così... anche con la JVM Microsoft! :confused:

Pandax
16-05-2004, 20.54.17
... comincio a essere felice... e a sentirmi meno stupido.. è da 5 giorni che vado avanti a formattare per sti problemi. :confused:

Grazie per l'info.

Pandax
16-05-2004, 20.59.16
in verità a me da anche qualche problemino con aruba...

guarda qua...

ps in questo momento ho installato win xp pro con SP1 ...IIS... Visual Studio .net.. e altri programmini.

e la Java Virtual Machine di Sun.

(quella di Microsoft per ora non l'ho installata)

The Saint
16-05-2004, 21.07.20
Vai nelle Opzioni Internet -> Avanzate e spunta la casellina "Disattiva debug degli script"....... può capitare che ci siano script buggati in giro, ma non è un problema nostro! ;)

Pandax
18-05-2004, 23.03.45
si è vero hai ragione, bastava quello...

ma ti chiedo un'altra cosina...

stasera stavo chattando su chat.tiscali.it (puoi andare a vederla non serve iscriversi)

è in java... e non mi funziona benissimo... ma portavo pazienza.

però a un certo punto il pc..mi è ... be.. andato in culo...

e credo sia colpa di java.. anche se in verità la cosa è ben strana...

guarda qui...


ps ho appena formattato installato Xp con Sp1 , framework , JVM sun, e altri programmi...

io credo sia colpa della JVM di Sun... ma non saprei come risolvere... magari bisogna configurarla.. ma non so come si fa... bo....

The Saint
19-05-2004, 11.11.13
Non saprei... non ci sono cose particolari da configurare.

Ma si inchioda solo con la chat o ti è capitato anche in altre occasioni?

Pandax
19-05-2004, 11.28.30
no direi solo con la chat...

diciamo che la JVM della Sun sembra abbia dei problemini con le chat...

quella di Lycos non la apre... chat.lycos.it

quella di Tiscali la apre ma non funziona molto bene... chat.tiscali.it (se vedi nell'immagine ci sono dei pulsantini a metà... mezzi neri.. ecco..dopo un po che la usi.. il pc .. fa casino.. e anche i menu delle finestre di windows impazziscono diventando mezzi neri..)

... sarei tentato di installare quella vecchia di Microsoft... ma so che poi non si disinstalla.. non vorrei fare ancora + casino.. tu cosa mi consigli?

grazie per l'aiuto. :wall:

The Saint
19-05-2004, 18.38.53
Originariamente inviato da Pandax
... sarei tentato di installare quella vecchia di Microsoft... ma so che poi non si disinstalla.. non vorrei fare ancora + casino.. tu cosa mi consigli?Se non l'hai disinstallata con l'apposito programmino messo a disposizione da MS, la Java MS è ancora presente... x usarla basta disattivare quella di Sun (era x questo che ti avevo chiesto di provare il jview); vai nel pannello di controllo "Java Plug-in" -> "Browser" e togli la spunta da Internet Explorer.

In pratica in questo modo puoi velocemente "switchare" tra una e l'altra. ;)

Pandax
19-05-2004, 18.55.41
Guarda con jview non da nulla... quindi deduco che non ci sia la JVM di microsoft. (infatti se non sbaglio con win xp mettendo il SP1, la JVM non dovrebbe esserci)

Quindi... potrei installarla (la JVM di Microsoft) e poi switchare seguendo le tue istruzioni. (basta togliere quella spunta vero... non serve altro?)

Sulla Versione da installare cosa mi consigli?

Su questo sito http://home.wanadoo.nl/jheroen/VM/downloads.htm

c'è la 3805 con le 2 fix 3809 e 3810 ... che dici installo queste nell'ordine come stanno?

se no io ho una vers. 3809... te che dici? ^_^

p.s. scusa se stresso tanto con sta JVM... ma non riesco a farla funzionare in modo decente.

The Saint
19-05-2004, 19.05.43
Originariamente inviato da Pandax
Guarda con jview non da nulla...Hai provato a lanciarlo da finestra DOS (Prompt dei comandi)?

Cmq in caso direi di mettere la 3809 e poi la aggiorni a 3810...

Pandax
20-05-2004, 09.46.41
si provato non da nulla. ok, proverò a installare come dici tu. poi ti dirò... speriamo :rolleyes: