PDA

Visualizza versione completa : vmware 3 workstation


nana_d
15-04-2003, 15.52.20
Non sono ancora riuscito a farlo funzionare, dopo aver installato .rpm e VMwareWorkstationKernelModules-3.0.0-1491.i386.rpm, lancio vmware-confi.pl e alla fine mi f uscire con un errore.
St provando sulla RH 8.0.A
A presto posto l'errore x potervi essere di aiuto
grazie

pholcus
15-04-2003, 17.17.00
Io ce l'ho sotto la slack e funziona molto bene..ho provato a farci girare su anche Longhorn e funzionava :D

nana_d
15-04-2003, 21.58.34
Pholcus io non sono mica bravo come t:) a configurare il sistema;)

pholcus
16-04-2003, 09.22.51
No, lol...ora mi ricordo che avevo dovuto creare delle dele cartelle in /etc/rc.d se nn mi sbaglio, perche' se non non si installava...
Ah, poi a volte quando si fanno partire le schede di rete virtuali non partono...

Ciao

PS: posta l'errore cosi ti possiam aiutare..;)

nana_d
17-04-2003, 14.27.26
[root@ndinet root]# vmware-config.pl
Making sure VMware Workstation's services are stopped.

Stopping VMware services:
Virtual machine monitor [ OK ]

Trying to find a suitable vmmon module for your running kernel.

None of VMware Workstation's pre-built vmmon modules is suitable for your
running kernel. Do you want this script to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.4.18-24.8.0/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

make: Entering directory `/tmp/vmware-config6/vmmon-only'
make[1]: Entering directory `/tmp/vmware-config6/vmmon-only'
make[2]: Entering directory `/tmp/vmware-config6/vmmon-only/driver-2.4.18-24.8.0'
In file included from ../linux/driver.c:38:
/lib/modules/2.4.18-24.8.0/build/include/linux/malloc.h:4:2: #error linux/malloc.h is deprecated, use linux/slab.h instead.
make[2]: *** [driver.d] Error 1
make[2]: Leaving directory `/tmp/vmware-config6/vmmon-only/driver-2.4.18-24.8.0'make[1]: *** [deps] Error 2
make[1]: Leaving directory `/tmp/vmware-config6/vmmon-only'
make: *** [auto-build] Error 2
make: Leaving directory `/tmp/vmware-config6/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please havea look at "http://www.vmware.com/download/modules/modules.html".

Execution aborted.

[root@ndinet root]#

pholcus
17-04-2003, 14.45.19
Puoi provare a installare un kernel nuovo..ma non ti assicuro che funzioni..
oppure provare a cambiare il file di include, cioe' apri il file ../linux/driver.c e al posto di
#include <linux/malloc.h> metti #include <linux/slab.h>
ma non so se funziona..anzi..

nana_d
17-04-2003, 20.43.59
B se ci riesco provo! grazie Pholcus sempre presente :)

nana_d
18-04-2003, 09.39.01
Nessun risultato, anzi togliendo gli rpm e provando con i tarball stato peggio: non sono proprio arrivato in fondo all'installazione!
Forse perch ho montato XFree 4.3.0? B ritento a presto!

JMass
19-04-2003, 11.38.59
VMware 3 non supporta i kernel pi recenti, l'ultimo ufficiale redhat che dovrebbe funzionare quello fornito con la 7.3, ad ogni modo uscita la versione 4 di vmware che dovrebbe funzionare.
Ciao