PDA

Visualizza versione completa : In exel, funzione SE complicata


musicboy
08-04-2003, 15.14.31
Ciao,
io dovrei, con la formula SE, fare la seguente operazione:
se in una cella ho un valore compreso tra 0 e 6, mi deve dare un risultato fisso(per es. 10%), se ho un valore che è compreso tra 7 e 9 mi deve dare per es. questo risultato fisso 20%, se ho un valore che è 10 o superiore mi deve dare per es. 30%.
Come posso fare?

Grazie e ciao

haldo
08-04-2003, 22.39.52
...nella cella A1 c'è il valore che devi valutare.....


=SE(E(A1>0;A1<=6);"10%";SE(E(A1>6;A1<=9);"20%";"30%"))


fammisapè se va bene.......

exion
08-04-2003, 22.39.56
devi nidificare due funzioni se.

Se ad esempio i tuoi dati sono inseriti nella colonna B, a partire dalla cella B6, la tua formula dovrebbe essere:

=SE(B6<7;"10%";SE(B6>9;"30%";"20%"))


che interpretata passo passo, per capire meglio, sarebbe:

se b6 è minore di 7, allora scrivi "10%"
=SE(B6<7;"10%";SE(B6>9;"30%";"20%"))

altrimenti se b6>9, allora scrivi "30%"
=SE(B6<7;"10%";SE(B6>9;"30%";"20%"))

altrimenti scrivi "20%"
=SE(B6<7;"10%";SE(B6>9;"30%";"20%"))