PDA

Visualizza versione completa : Problema masterizzatore


Marko
09-11-2002, 15.03.51
Ho installato il nuovo kernel 2..4.19 su redhat 8 e mi ha riconosciuto tutto (nessun errore nella fase di boot) solo che non mi vede il masterizzatore:(
Ho messo scsi emulation support come modulo e abilitato il supporto SCSI.
Ho compilato poi i moduli con make modules e make modules_install.
Adesso uso il 2.4.19 e quando devo masterizzare vado col kernel originale di redhat.
Cosa devo impostare per fare riconoscere il masterizzatore???

Ibanez
09-11-2002, 15.30.53
Hai messo il supporto per i cd-rom ide nel kernel? Se si toglilo, va in conflitto con l'emulazione scsi

Marko
09-11-2002, 15.38.20
Originariamente inviato da Ibanez
Hai messo il supporto per i cd-rom ide nel kernel? Se si toglilo, va in conflitto con l'emulazione scsi

Ah ecco allora questo il problema. Si ho messo il supporto per cdrom ide nel kernel adesso provo a disabilitarlo e a ricompilare.
Ti faccio sapere.

Marko
10-11-2002, 12.21.06
ho ricompilato ma se tolgo il supporto ide cdrom dal kernel non mi vede i lettori cd.
Non un grosso problema perch come ho detto tengo il kernel vecchio e lo uso solo per masterizzare per mi sarebbe piaciuto fare andare anche il masterizzatore, l'ultima cosa che devo fare andare x il resto funge tutto.
L'errore che mi da quando faccio cdrecord -scanbus :

cdrecord: no such file or directory. Cannot open /dev/pg* Cannot Open SCSI Driver

Ibanez
11-11-2002, 01.57.14
Allora che hai messo nella sezione scsi? Hai aggiunto le solite righe nel nuovo kernel "hdx=ide-scsi" ?

Marko
11-11-2002, 04.12.54
Originariamente inviato da Ibanez
Allora che hai messo nella sezione scsi? Hai aggiunto le solite righe nel nuovo kernel "hdx=ide-scsi" ?

Si le ho messe le righe ma non funge lo stesso :(

Ibanez
11-11-2002, 10.05.26
Nella sezione scsi del kernel cos'hai messo?

Marko
11-11-2002, 20.15.58
Ho abilitato solamente scsi support e basta; forse questo il problema, devo abilitare anche scsi disk support???
Un'altra cosa: all'avvio mi dice che non trova il modulo della scheda audio snd-emu10k1 anche se per la live funge.
Pu essere che io metto scsi emulation support ma lui non compila correttamente i moduli???
Io do make modules e make modules_install, devo modificare qualche files per farlo puntare alla nuova directory /lib/modules/2.4.20-rc1???

Ibanez
11-11-2002, 20.49.20
devi abilitare anche scsi cd-rom support.
Per quello devi modificare gli header del kernel dwevi modificare il makefile nella dir dei sorgenti del kernel e mettere quello che vuoi dopo la versione del kernel in extraversion:
esempio
VERSION = 2
PATCHLEVEL = 4
SUBLEVEL = 20
EXTRAVERSION =rc1
Cosi hai imoduli nella dir /lib/modules/2.4.20_rc1
Tranquillo se non c' la crea lui....

Marko
12-11-2002, 20.08.33
Grazie per i tuoi consigli. Oggi domani mi arrivata la Mandrake 9 Powerpack, se non sta sera domani mattina (mi sveglio prestissimo e la installo) seguendo i tuoi consigli per la partizioni e poi mi ributto nella compilazione del kernel sperando di riuscire a far fungere sto benedetto masterizzatore con il nuovo kernel :(
I moduli me li mette in /lib/modules/2.4.20-rc1 per come ti ho detto non trova i moduli per la scheda audio snd-emu10k1 anche se non l'ho abilitato come modulo e la scheda video funge lo stesso.
Quando era come modulo il supporto per la live emu10k1 mi dava lo stesso identico problema che non trovava il modulo e mi dava errore all'avvio di kde in /dev/dsp diceva no such file or directory, ma abilitando non come modulo la live funge.

Ibanez
12-11-2002, 21.43.13
ma il modulo per la live si chiama emu10k1 non snd-emu10k1. Prova con modprobe emu10k1 e vedrai che funge anchecome modulo.

Marko
13-11-2002, 04.10.40
Mi dice can't locate module emu10k1 anche se abilitato come modulo l'opzione per la live emu10k1.

Ibanez
13-11-2002, 09.39.49
Che moduli hai attivato nella sezione audio?
Prova a vedere se te lo ha creato, nella dir /lib/modules/versione

Marko
13-11-2002, 12.10.18
Originariamente inviato da Ibanez
Che moduli hai attivato nella sezione audio?
Prova a vedere se te lo ha creato, nella dir /lib/modules/versione

Si si, li il modulo c'.
La cosa strana che con redhat a parte il masterizzatore che non fungeva sempre i moduli li caricava senza nessun problema ma qui con mandrake niente :(

Sono tentato di ritornare a RedHat 8 e poi installo il software che c' sui cd di mandrake 9 su redhat 8.

Ibanez
13-11-2002, 13.07.33
Dimmi che ci hai messo nella sezione audio del kernel e assicurati che i moduli li carichi da l (puoi vederlo dai file di avvio, o dai messaggi di avvio se non hai il login grafico o dai log di sistema).

La mdk mi ha dato spesso prob come questi, sempre con le 128 per mai con le live. Cmq mettere direttamente nel kernel non una brutta idea, si mettono come moduli solitamente le periferiche che non ti servono sempre caricate,difficilmente toglierai l'audio in un desktop.

Marko
13-11-2002, 16.01.42
Originariamente inviato da Ibanez
Dimmi che ci hai messo nella sezione audio del kernel e assicurati che i moduli li carichi da l (puoi vederlo dai file di avvio, o dai messaggi di avvio se non hai il login grafico o dai log di sistema).

La mdk mi ha dato spesso prob come questi, sempre con le 128 per mai con le live. Cmq mettere direttamente nel kernel non una brutta idea, si mettono come moduli solitamente le periferiche che non ti servono sempre caricate,difficilmente toglierai l'audio in un desktop.

Allora nella sezione audio del kernel ho messo:

Sound support: y
Sound Blaster Live Support: m
Creative Sound Blaster Live MIDI: m

Poi ho anche provato a mettere Sound support come modulo ma niente mi da sempre lo stesso errore.

Sto meditando alla grande di passare nuovamente a redhat e installo tutto il software che mi serve che ho sui cd della mdk9 powerpack come star office.

Ah una cosa: Star Office la licenza mi permette di installarlo solamente su mandrake oppure anche su altre distribuzioni???

Ibanez
13-11-2002, 20.21.39
Prova vedere se li carica dalla dir giusta.....

No star office puoi installarlo anche su RH. Attento che qualche rpm di mdk potrebbe non funzionare, perch ottimizzato per mdk.