PDA

Visualizza versione completa : Lilo


Alef
10-06-2002, 21.54.40
Ho la Redhat 7.3 e lilo non funge, ho questo messaggio di errore:

Configurazione non OK. LILO ha detto:
Warning: device 0x0306 exceeds 1024 cylinder limit
LILO version 21.4-4 (test mode), Copyright (C) 1992-1998 Werner Almesberger
'lba32' extensions Copyright (C) 1999,2000 John Coffman
Reading boot sector from /dev/hda
Merging with /boot/boot.b
Fatal: geo_comp_addr: Cylinder number is too big (2041 > 1023)

La cosa strana che fino a 15 giorni fa avevo la Mandrake e lilo funzionava, non ho cambiato niente, sulla partizione che montava Mandrake adesso ho la Redhat.
Che devo fare?

Bye

Alef

Manlio
10-06-2002, 22.00.57
:o davvero molto strano...
ho la rh 7.3 installata e funge con lilo ben oltre il 1024 cilindro (fatidico!...)

posta un po' il lilo.conf...
che modello di disco hai?

Alef
10-06-2002, 22.22.43
Il mio lilo.conf dovrebbe essere questo

boot="/dev/hda"
prompt
timeout="50"
message=/boot/message
root=/dev/hda7
vga="predefinit"

image="/boot/vmlinuz-2.4.18-3"
label="2.4.18-3"
root="/dev/hda7"
read-only
initrd="/boot/initrd-2.4.18-3.img"

image="/usr/src/linux/arch/i386/boot/bzImage"
label="Linux_Compiled"
root="/dev/hda7"
read-only
optional

other=/dev/hda1
label="NT"
image="/dev/hda1"
root="/dev/hda7"
initrd="/boot/initrd-2.4.18-3.img"

La Rh funziona alla grande solo devo fare l'avvio da dischetto che lungo e noiosetto, volevo sveltirlo con lilo. Il mio hd un Samsung ma non credo dipenda da questo, con Mndrake lilo fungeva.

Bye

Alef

Manlio
11-06-2002, 01.01.12
prova ad aggiungere al primo blocco lba32...
e logicamente dai poi al prompt lilo -v -v... ed osserva che dice...

Alef
11-06-2002, 22.26.34
Ho attivato lba32 e ora tutto ok!
Quando ho messo lilo come bootloader ho lasciato le impostazioni che suggeriva anaconda che non mette lba di defualt.

Tnx ;)

Alef

Manlio
12-06-2002, 00.58.14
felice di averti aiutato!