PDA

Visualizza versione completa : Corel Linux (Xfree 3.3.5)


Marko
03-04-2002, 17.36.08
Allora ieri mi sono messo in testa di voler installare Corel Linux a tutti i costi solo che sapevo che Corel Linux 1.0 aveva Xfree 3.3.5 e che la mia Nvidia Riva TNT2 non era supportata da quella versione di xfree.
Allora mi sono scaricato il mio Xfree 4.2.0 e poi ho iniziato l'installazione di Corel Linux 1.0 sul mio Pentium 3 800.
Terminata l'installazione con mia grande sorpresa, si avvia in modalità grafica e mi riconosce la scheda video e la mette ad una risoluzione di 65536 colori a 1024x768 X 60Hertz.:eek::eek::eek:
Secondo voi com'è possibile che nella lista delle schede supportate da xfree 3.3.5 la mia non ci sia ma venga vista e riconosciuta???

Secondo: vorrei aggiornarmi adesso questa versione di corel Linux con gli ultimi software disponibili (kde 2.2.2 gnome 1.4 kernel 2.4.18 gcc 3.0 e via dicendo): è un impresa da pazzi o si può fare???
Io mi son sempre trovato molto bene con corel linux e vorrei continuare ad usarlo.


Ultima cosa che però non riguarda questa cosa: prima quando sul p3 non avevo corel linux avevo redhat 7.2 deluxe e sul mio Athlon ho ancora adesso mdk 8.1 però mi è successa una cosa strana: prima quando dovevo riconfigurare lilo da una console digitavo lilo da root e tutto funzionava poi (sarà una coincidenza o no) da quando hanno cambiato l'ora se io scrivo lilo mi da command not found e per lanciarlo devo andare in /sbin e dare il comando ./lilo
Che può essere???


GRAZIE


MARKO

EcHo2K
04-04-2002, 01.48.57
il fatto che la scheda vada probilmente significa che stai usando il server x SVGA standard, non ti aspettare accelerazioni 3d di sorta...

per quanto riguarda gli aggiornamenti...socondo me non sono da farsi...cioe' per rendere attuale corel linux 1 dovresti

a. aggioranre il kernel alla 2.4.x

b. aggioranre xfree86 alla 4.x

c. aggiornare la libc

d. aggiornare kde

e. aggioranre un'altra miriade di pacchetti...

in pratica ti crei una distribuzione tua basata su corel :D

senza considerare il fatto che corel usa una versione customizzata forte di KDE 1, passando a kde2 perderesti tutte queste caratteristiche che ti fanno voler bene a corel :)
fai come me (anche a me era piaciuta abbastanza la corel 1, anche se avevo dovuto smandruppare un po' per riuscire a installare i development tools che nell'installazione standard ignora completamente...) aspetta sto cazz di Xandros che dovrebbe riprendere il filo del discorso da dove corel lo aveva lasciato... www.xandros.com

pctips
05-04-2002, 16.40.47
allora marco , dovresti aggiornare kernel , pacchetti vari , kde , gnome , le librerie e xfree
Una operazione non difficile ma che richiede tempo.
E' normalissimo che xfree 3.3.5 riconosca la tua scheda video : nel kernel sono implementati alcuni driver di schede grafiche ed ottimizzazioni specifiche.Mi sembra che durante la compilazione del kernel ci sia un menu specifico (da x con make xconfig) x queste ottimizzazioni , e quando viene scelto un modello di scheda (es. la mia g200) viene automaticamente installato il modulo del driver.
Lilo non si avvia perchè devi modificare la variabile d'ambiente PATH in /etc/profile mi sembra , cmq il file di configurazione di bash
In mdk ad esempio /usr/local/bin non è di default in $PATH
Ciao

EcHo2K
08-04-2002, 11.20.26
giusto per non fare confusione...i driver del kernel di cui parli sono i driver DRI (dri.sourceforge.net) che servono per l'accelerazione 3d, sono presenti solo nel kernel 2.4 e successivi, corel linux 1.0 e' basata sul kernel 2.2.13 se non sbaglio quindi non ha driver per schedevideo in kernel space.

pctips
14-04-2002, 11.36.08
No anche il kernel supporta le schede grafiche , comprese quelle nuove e vecchie , altrimenti andrebbe sempre in panic.
Probabilmente la TNT2 include molte caratteristiche che la rendono simile alle sue predecessori che sono supportate da xfree.
Scusate nel ritardo a postare ma sono tornato a casa da una gita solamente ieri notte alle 11
Ciaoo

EcHo2K
16-04-2002, 20.26.54
che il kernel 2.4 supporti direttamente le schede video non lo mette in dubbio nessuno, il 2.2 invece ha solo l'agpgart, non mi ricordo di aver mai visto caricare moduli specifici al 2.2, Xfree invece ha sempre avuto supporti specifici per le schede video.

cmq chiedo scusa se dico delle cazzate, ma sinceramente non mi ricordo drivers specifici per schede video nella configurazione del 2.2

pctips
17-04-2002, 18.12.26
Sì in effetti nella versione "vanilla" (cioè senza modifiche) nel 2.2.* è previsto solo /dev/agpgart , mentre è comunque possibile applicare patch e creare nuovi moduli.
Penso che Corel abbia implementato dei moduli che allora erano beta nella sua distro
Ciao