PDA

Visualizza versione completa : VNC Server


MasterBrian
03-09-2001, 10.49.27
Salve a tutti,

ho un problema con il mio vncserver, quando lo lancio e vado a leggere il log ho questo:

xterm Xt error: Can't open display: %s

03/09/01 09:07:36 Got connection from client XXX.XXX.XXX.XXX
03/09/01 09:07:37 Protocol version 3.3
03/09/01 09:07:41 Pixel format for client XXX.XXX.XXX.XXX:
03/09/01 09:07:41 8 bpp, depth 8
03/09/01 09:07:41 true colour: max r 7 g 7 b 3, shift r 0 g 3 b 6
03/09/01 09:07:41 no translation needed
03/09/01 09:07:41 Using hextile encoding for client XXX.XXX.XXX.XXX
03/09/01 09:07:41 rfbProcessClientNormalMessage: ignoring unknown encoding type
3

Se mi connetto mi chiede la password, la accetta, arrivo dopo qualke secondo alla schermata del vnc ma non riesco a fare niente... qualcuno mi puo' aiutare perfavore?
Grazie a tutti!

aro
03-09-2001, 11.11.20
Non mi mai capitato, ma hai provato a mettere tra le opzioni del VNC viewer prima della connessione sotto a display l'apicetto su Restrict pixels to 8-bit? Comunque immagino possa anche essere un problema di differenza eccessiva di risoluzione grafica tra client e server.

MasterBrian
03-09-2001, 12.13.40
Grazie per la risposta velocissima,
temo che non sia un problema di risoluzione, infatti dovrebbe funzionare anke in java (connettendosi all'ip della macchina su cui gira il server e alla porta 58+numero virtual dekstop, per esempio per il desk 01 http://xxx.xxx.xxx.xxx:5801), quindi in maniera completamente estranea dalla risoluzione giusto? E poi nel log vedo diversi errori! :(