PDA

Visualizza versione completa : ma softice funziona con windows ME??


mag
25-07-2001, 20.02.59
grazie a chi mi puo' dare un a aiuto.

ciao

debe80
26-07-2001, 00.49.02
Si ma devi avere la versione 4.05. Se ce l'hai ed è la versione contenuta nel Driverstudio 2.0 per farlo funzionare devi scaricare il microsoft developer kit (DDK) dal sito della microsoft. Questo pacchetto ti installa un io.sys modificato fatto apposta per i debuggers. Ti rimando alla seguente pagina dove ci sono esaurienti spiegazioni:

http://www.numega.com/drivercentral/tech_tips/windows-me_6_30_00.shtml

Segui le istruzioni alla lettera e ricordati di scaricare anche il file debugger.exe sempre dal sito della numega.
Così facendo caricherai Softice ad ogni riavvio del pc. Se non lo vuoi caricare ogni volta c'è una piccola utility chiamata Winice Loader e la trovi qui:

http://www.programmerstools.com/ sotto la sezione debuggers
ma prima di usarla devi cancellare il debugger.exe e rimettere il io.sys originale (almeno io ho fatto così)

Se hai una versione 4.05 standalone (che possedevo io poco tempo fa ma che era meno compatibile con schede nvidia e di ultima generazione) dovresti poter installare Softice senza l'io.sys modificato. Fai partire il programma di installazione: quando il programma ti chiederà se vuoi modificare autoexec.bat e config.sys tu scegli di NON MODIFICARLI. Installa il Winice Loader e tutto dovrebbe funzionare a meraviglia. In entrambi i casi comunque installa i driver video come standard vga.

mag
26-07-2001, 08.55.53
grazie!

se ho ben capito usando il winice loader non ho bisogno di modificare io.sys e caricare debugger.exe, corretto?

e perdipiu' posso caricare softice solo quando ne ho bisogno e non ad ogni avvio.

ciao

debe80
27-07-2001, 01.20.01
L'io.sys modificato ed il debugger.exe (ti parlo per esperienza personale poichè avevo tutte e due le versioni del softice 4.05) va installato obbligatoriamente con la build 526 credo del driverstudio 2.0 (nel senso che altrimenti il softice non lo riesci materialmente ad installare in quanto al momento dell'installazione ti appare una simpatica finestra che ti dice di installare il ddk).Puoi comunque farlo partire con il winice loader cancellando il debugger.exe e rimettendo l'io.sys originale(io ho fatto così e funziona) Se hai un altra versione del softice 4.05 che al momento dell'installazione non ti mostra alcun messaggio particolare riguardante Winme e ddk puoi andare tranquillo direttamente con il winice loader. Per evitare il caricamento del softice tramite winice loader devi premere esc durante il boot di winme (ti apparirà una barra di progressione del tempo con una scritta e tu devi premere esc in tempo)

mag
27-07-2001, 10.05.01
grazie

io ho la build 334.

ieri sera sono riuscito a farla funzionare senza installare le ddk, solo utilizzando il loader.

l'unica cosa e' che ho dovuto spostare wince.exe, winice.dat e siwvd.386 dal diorettorio dove erano installati di default programmi/numega.... nel direttorio c:/windows; senza qs modifica non ne voleva sapere di caricare il programma.

grazie ancora e ciao