PDA

Visualizza versione completa : Comportamento inspiegabile di un HD SATA


Netlix
24-01-2010, 17.05.27
Ciao a tutti ! Allora... tanto per complicarmi la vita.

Ho un SATA HITACHI HDS721010CLA332 da 1 TB formattato e praticamente pieno.
Formattato da zero 1 mese fa con XP SP2, opzioni di boot e usato come disco secondario su un PC per un mesetto tramite schedina PCI-SATA che l'ha fatto andare a 1,5 GB/s di transfer rate. Perfetto.

Ora voglio trasferirlo su una MB ASROCK G41m-GS, che ha la MB con controller SATA integrato, con velocità di transfer rate di 3GB.
Se lo metto come SATA primario... parte, ma a metà del caricamento del SO, fa un reboot.
I drivers della vecchia scheda non vanno, e mandano in palla il tutto. Tutto come al solito. Visto mille volte !

Quindi installo il lettore CD, e faccio partire l'installazione di XP SP2, per fargli aggiornare i driver.
Ma qui arriva il "colpo di scena". Invece di chiedermi quale installazione recuperare, me lo indica quale NON FORMATTATO o con formattazione "anomala". Ma non dovrebbe caricare un driver SCSI/SATA universale almeno per l'installazione?

Se lo faccio ripartire con il SATA quale primario di BOOT, continua a vederlo, e a partire con il caricamento del sistema operativo, anche in modalità provvisoria-
Per capirci, da la videata di windows XP con la barra che scorre, e dopo dieci secondi circa, reboota.

E ora che faccio?
Ho letto da qualche parte dell'esitenza di una funzione "SPREAD SPECTRUM" che altererebbe il protocollo di trasmissione dei dati,
Inoltre sembra che alterare la velocità da 1,5 a 3,0 Gb/s possa rendere il disco non leggibile.

C'entra qualcosa?

Per fare qualche test, ho formattato e inizializzato un'altro SATA, per utilizzarlo come disco di boot (installazione perfetta e tutto a posto) e ho messo il Terabyte come secondario. Giusto per vedere COME lo legge...
Il sistema è rallentato paurosamente. Mezz'ora e ho il desktop con la barra start, ma non ho ancora le icone...

Sembra che la presenza contemporanea dei due SATA, faccia si che si "intralcino"...
Per inciso, ora su qualsiasi pc che collego il disco "grande", lo rallenta in maniera catastrofica. Per capirci, 40 minuti tra l'accensione e la compasa delle icone, e qualsiasi cosa lentissima nonostante il processore al 2%

Se lo tolgo, il pc riprende a funzionare correttamente.

Che mi consigliate?

Jedi-78
28-01-2010, 09.56.35
allora... iniziamo col:

aggiorna il BIOS della scheda madre
aggiorna il driver del controller SATA della scheda madre

hai provato a collegare il disco ad un altro computer montante un sistema operativo più recente (Win Vista o Seven)? Non so quanto XP sia in grado di gestire una partizione da 1TB...

Netlix
28-01-2010, 15.17.39
allora... iniziamo col:
aggiorna il BIOS della scheda madre
aggiorna il driver del controller SATA della scheda madre

hai provato a collegare il disco ad un altro computer montante un sistema operativo più recente (Win Vista o Seven)? Non so quanto XP sia in grado di gestire una partizione da 1TB...

I drivers sono già aggiornati. Appena acquistata la mainboard, é la prima cosa che faccio. [Parakoolo mode ON] :)
Inoltre la scheda madre ASROCK ha un'utility veramente pratica. :act:

il TB é stato montato quale disco secondario su un PC con XP SP2 la sera di Natale, e ha funzionato ininterrottamente 24/24 (e in maniera "pesantuccia") fino ad una settimana fa quando ho DOVUTO cercare di renderlo primario.

L'installazione di XP ha fatto il danno... :wall:

Attualmente la situazione é questa.:

Facendo partire il PC con il CD di BOOT creato da Acronis Disk directory, l'utility riconosce il disco, con dimensione ed occupazione spazio corretta.
La struttura delle directory é perfetta.
Ma al momento di copiare i files dal disco "sballato" ad uno "buono" installato come secondario, l'utility Acronis si blocca.

Ho provato ad avviare con il CD di SysteRescueCD versione 1.3.4
Ho avviato il SW TestDisk 6,1,1 incluso nel CD, ed accade una cosa strana...
Esegue in sequenza:
Select a media (e lo trova): 1000 GB / 931 GiB ATA Hitachi ( e cita l'etichetta del HD )
Proceed analyze: HPTS-NTFS Start 0 1 1 121600 End 254 63 1953520002
.. ma nella videata successiva, mi dice"The harddisk (1000 GB /931GiB) seems too small! (2000 GB/1863 Gib).
Quindi si incasina sulla dimensione. potrebbe essere quello che rallenta il sistema?

Ma proseguendo, e richiedendo la lista dei files, trova tutto: nomi dei files, dimensioni, data ultimo aggiornamento...
Ho davanti al naso tutta la struttora del disco. Mi sembra di essere ad un passo da risolvere, ma altrettanto da fare il "danno perfetto" e distruggere tutto.

Mi consigliate un'utility che parta da CD o PenDrive che possa risolvere tale problema? Oltretutto, certi SW segnalati come freeware...
non lo sono più :inkaz: