PDA

Visualizza versione completa : aiuto per foglio DATI excel


Valery
28-01-2009, 11.55.28
Sto lavorando ad un mio piccolo database, ma sono un pò imbranata con l'uso delle formule. Ho creato una tabella con questi campi:
nel foglio DATI, nella cella G ho l'età, nella cella H M (maschio) o F (femmina). Nel foglio RIEPILOGO vorrei sapere quanti sono i maschi dai 18 ai 24 anni, dai 25 ai 30 ecc e lo stesso x le femmine. So che è un calcolo semplice ma non riesco a incrociare i dati. Qualcuno mi può aiutare in modo semplice e chiaro?
Grazie!!!! :)

pietrol
30-01-2009, 23.27.10
Ciao Valery
non ti abbattere, quello che chiedi non è proprio una cosa banale come ti sembra.
Vediamo come procedere:
ci spostiamo nel foglio Riepilogo
in cella A1 scrivi "Da"
In cella B2 scrivi "A"
Nelle celle sottostanti scrivi le età minime e massime delle fascie che vuoi sommare
18 24
25 30
ecc.
in cella C1 scrivi "F"
in cella D1 scrivi "M"
nella cella C2 incolli la seguente formula

=MATR.SOMMA.PRODOTTO(--((DATI!$G$4:$G$43)>=$A2);--((DATI!$G$4:$G$43)<=$B2);--(DATI!$H$4:$H$43=C$1))

modifica la formula sostituendo dappertutto il 4 con la prima riga effettiva del tuo elenco nel foglio DATI e il 43 con l'ultima riga.

Copia la formula nella cella accanto e poi nelle stesse colonne di fianco a tutte le altre fasce le età.
A questo punto dovresti avere quello che ti serve.

Ciao
pietrol