PDA

Visualizza versione completa : NET Framework su XP


SK888
25-09-2008, 07.38.53
ciao
ieri, per far funzionare un applicazione nuova, sono stato costretto ad installare il framework 3.5.
Siccome già in passato sono stato ovviamente costretto ad installare i framework richiesti dalle varie applicazioni di volta in volta ora mi trovo ad avere installato

framework 1
framework 1.1
framework 2
compact framework 2
framework 3
framework 3.5

tutti con i rispettivi service pack.

volevo sapere :mm: ma sono tutti necessari ?
Il 3.5 non è l'ultima versione percui include tutta la tecnologia dei precedenti ? Bisogna tenerli tutti installati ?

Grazie, ciao

Aquax
25-09-2008, 11.00.53
Purtroppo si.
O meglio, l'1.1 di sicuro, anche se sono sempre meno le applicazioni che ormai si basano sulla 1.1.

La 3.5 invece dovrebbe comprendere anche la 2.

Quindi dovresti installare la 3.5 e la 1.1 x avere tutto completo. ;)

SK888
25-09-2008, 11.16.08
grazie, però continuo ad avere dubbi. :mm:
perchè l'installer del framework 3 è più pensate di quello del 3.5 ?
e poi, perchè devo tenere installato il Compact framework 2 se ho installato il framework 2.
"Compact" non significa che è una versione più leggera della 2? Come SQL server express che è una versione minima di SQL server?

Aquax
25-09-2008, 11.31.26
Sul COMPACT non ti so dire. Io ho sempre installato il 3.5 (in realtà ho sempre integrato il 3.5), e anche l'1.1 (solo x evitare di doverlo installare in seguito), e mi sono sempre funzionate tutte le applicazioni in .Net che uso, come ProgDVB, Paint.net, nLite.

Dicci magari quale applicazione ti richiede il .NetFramework. ;)

Cmq, se installi solo il 3.5 e l'1.1 dovresti essere a posto.

borgata
25-09-2008, 11.31.36
Leva tutto e pulisci il registro.
Installa il 3.5 e vedi se i programmi che ti interessano funzionano, in caso contrario installa il framework richiesto (che nel caso sarebbe l'1.1, il 2sp1 e il 3sp1 vengono installati direttamente dalla 3.5).

SK888
25-09-2008, 11.55.18
ecco qui i programmi che mi richiedono il framework:

sony acid - framework 1
microsoft autoroute - framework 1.1
(una applicazione di personalizzazione shell) - framework 2
sony soundforge e vegas - compact framework 2
autocad 2009 - framework 3
sql server 2008 - framework 3.5 + windows installer 4.5

comunque grazie, mi serviva proprio la sicurezza di sapere cosa include il 3.5
stasera provo
grazie, ciao

SK888
26-09-2008, 08.45.45
:mm:
insomma ho rimosso tutti i framework ad eccezione dell'1.1 ed ho installato il 3.5.
insomma mi sono ritrovato nuovamente installati i framework esattamente come prima e non era quello che mi aspettavo.
pensavo che il 3.5 fosse cumulativo cioè incorporasse i precedenti framework, ma in una installazione singola e non in installazioni separate.

vabbè, è obbligo tenerli così insomma. ;)

grazie a tutti
ciao

borgata
26-09-2008, 10.25.50
In effetti si, a quanto pare fa installazioni separate, ma non preoccuparti, la differenza sta solo nel pannello di installazione applicazioni.
Io se posso evito l'installazione del net framework, che è un po' pesante per il sistema, anche perché finora non ho trovato programmi che lo utilizzano di cui non ho trovato sostituto.

pazzokramaz
11-10-2008, 04.48.16
Ciao Ragazzi :)

VI CONSIGLIO ALTAMENTE DI RIMUOVERE TUTTI I .NET!
riavviare..
ED INSTALLARE SOLO QUESTO: Microsoft .NET Framework 3.5 Service Pack 1
(Link Sotto) contiene tutti in uno ;) (meno che l'1.1 ma è Obsoleto e ve lo sconsiglio, poco ottimizzato e pesante)
http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe
Pagina (scaricate il pakketto cumulativo, non quello da 2 mega):
http://www.microsoft.com/downloads/details.aspx?familyid=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=it

SINCERAMENTE PARLANDOCI CHIARO ;)
io sono rimasto sconvolto dalla pesantezza di questi .NET e dalla
mastodonticità della macchina che creano.. rimpiango le librerie VisualBasic!
pesi! Stra Pesi! sia 1.1 che il 3.5sp1 mi hanno dato problemi di lentezza e stabilità!
uso xp pro moddato con nlite e il net 3.5sp1 full si è installato
ma con alcune apllicazioni schianta, inoltre se clicco sulla icona che
mi mette nel pannello di controllo va in errore.
ah inoltre implementa parte di vista in xp
e poi mi vengono a dire che le dx10 su xp non vanno.. mah!

IO sto solo con il 2.0SP1 ;) Normale Meglio di nulla, Accettabile ;)
Vi metto il link ;) guardate, meglio il 2.0sp1 che tutto il casino..

http://www.microsoft.com/downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-A7633F706BA5&displaylang=it

ciao ;)

Aquax
11-10-2008, 09.22.26
Io ho sempre utilizzato XP con integrati .Net1.1 e 3.0 (Ora 3.5) e non ho mai riscontrato problemi.
Certo, il primo avvio di una qualsiasi applicazione .Net è lento, ma purtroppo su XP è così.

E comunque è la stessa cosa che abbiamo consigliato noi, e cioè di tenere solo l'ultima versione, la 3.5, e se necessità la 1.1. E basta. ;)
E nei programmi citati da SK888 ci sono:

sony acid - framework 1
microsoft autoroute - framework 1.1

ha quindi bisogno dell' 1.1.

Deep73
13-10-2008, 13.13.22
Certo, il primo avvio di una qualsiasi applicazione .Net è lento, ma purtroppo su XP è così.


Non c'entra XP. Al primo avvio compila l'applicazione. Un pò come quella chiavica di Java :devil: .

Deep73
13-10-2008, 13.14.47
Io comunque installo solo l'1.1 (per abitudine, visto che è integrato nel 2003) e il 2.0 SP1. Il 3.x mi è toccato installarlo solo su un pc perchè ho messo su Visual Basic 2008 Express.

Aquax
13-10-2008, 13.35.28
Non c'entra XP. Al primo avvio compila l'applicazione. Un pò come quella chiavica di Java :devil: .
Hai ragione, ma un pochino XP centra, dato che su Vista l'avvio risulta piu veloce. ;)