PDA

Visualizza versione completa : [Firefox e Vista]Problema dopo l'installazione


shadowDK
25-08-2008, 08.53.48
Ho un problema che non capisco con Firefox su Vista Home Premium...in pratica, eseguo l'installazione normalmente, installo nella cartella di default di Vista (C:\Program Files)e tutto va bene...quando provo ad eseguire firefox, per˛, non parte! Ho provato ad installare anche loggandomi come super administrator ma niente da fare!
Inoltre, dopo l'installazione ho provato a creare un file Prova.html sul desktop e a dirgli di aprirlo con firefox ma se clicco sul file mi compare un messaggio di errore che dice che il file Prova.html Ŕ inesistente.

Sono riuscito a trovare una parziale soluzione installando firefox su un'altra partizione (quindi non su quella di sistema) e in questo modo tutto funziona bene, ma vorrei sapere perchŔ non riesco a installare firefox su c...con altri software di qualsiasi genere (ho installato firewall, antivirus, anti malware, Opera, programma di backup...insomma un po' di tutto) non ho nessuno problema...

Qualcuno ha qualche idea?

RNicoletto
25-08-2008, 15.22.32
Domanda: prima di installare Firefox hai rimosso fisicamente il precedente profilo?

shadowDK
25-08-2008, 15.32.52
Ho disintallato utilizzando revo e poi ho cercato eventuali altre cartelle e file collegati a firefox (in realtÓ, la prima volta ho solo disintallato firefox utilizzando revo e spuntando la casella "elimina profilo" o qualcosa del genere dal disinstallatore di firefox, poi siccome non funzionava la seconda volta che l'ho disinstallato ho cercato i resti e li ho cancellati a mano...quando per˛ ho disinstallato per installare sull'altra partizione ho eseguito di nuovo la disintallazione come la prima volta, senza quindi cercare nulla manualmente)...

RNicoletto
25-08-2008, 17.22.31
Se vai su Start - Esegui e digiti " %APPDATA%\Mozilla\Firefox\Profiles\ " cosa ti compare?

shadowDK
26-08-2008, 09.28.19
Adesso (ossia con Firefox funzionante ma installato sulla partizione D), si apre la cartella C:\Users\mio_user\AppData\Roaming\Mozilla\firefox\ Profiles dove dentro trovo una cartella xxxxxx.default al cui interno vedo i dati del profilo che ho creato, quindi vedo le estensioni usate, i motori di ricerca personalizzati, i segnalibri e via dicendo...tuttavia, se accedo alla cartella C:\Users\mio_user\AppData\Local\Mozilla\firefox\Pr ofiles, vedo una cartella con lo stesso nome (xxxxxx.default) al cui interno trovo i dati della cache e alcuni file (due .MFL e uno .SQLITE) che non so cosa siano...se mi ricordo bene, per finire, era quest'ultima cartella (da Mozilla compreso in poi) che avevo cancellato manualmente...vuoi sapere altro?
provo a disinstallare firefox, a reinstallarlo su c e a riaprire questa cartella per vedere cosa succede?

tra l'altro, mentre ci sono, una curiositÓ: rispetto a xp, in Vista hanno cambiato la gestione dei dati delle applicazioni? Mi spiego, con xp se digitavo la scorciatoia %appdata% si apriva la cartella dei dati applicativi per l'utente che era, appunto, appdata (e qui erano elencate tutte le applicazioni)...con Vista sembra che questa cartella sia diventata appdata/Roaming...per˛, come per firefox, anche per altre applicazioni alcuni dati si trovano anche sotto appdata/Local e non solo sotto appdata/Roaming...