PDA

Visualizza versione completa : [Linux] Configurare la tastiera remota di X.Org


balubeto
14-04-2008, 18.41.24
CIAO

Uso la GNU/Debian Lenny Testing con GNOME.

Ho notato che, se da un computer Windows, instauro una connessione SSH-VNC verso il mio Server Linux avviando, su questo, un display X remoto sul quale viene eseguito GNOME, tale ambiente viene caricato in lingua inglese anziche` in italiano come avviene se lo uso in locale. In altre parole, GNOME, in locale, e` in italiano; mentre, in remoto, e` in inglese. Come mai?

Poi, ho notato che, caricando GNOME su un display X remoto, tutti i tasti SHIFT, il tasto CapsLock ed il tasto Block Scroll non funzionano. Come mai?

Poiche` devo usare la tastiera sia con il layout americano che con quello italiano, ho configurato il server X.Org in questo modo



PLUTO:~# cat /etc/X11/xorg.conf

# xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the xorg.conf manual page.

# (Type "man xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"

RgbPath "/usr/share/X11/rgb"

FontPath "unix/:7100"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "us,it"

# Option "XkbVariant" "intl,nodeadkeys"

Option "XkbOption" "grp:alt_shift_toggle"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ExplorerPS/2"

Option "Emulate3Buttons" "true"

EndSection

Section "InputDevice"

Identifier "Synaptics Touchpad"

Driver "synaptics"

Option "SendCoreEvents" "true"

Option "Device" "/dev/psaux"

Option "Protocol" "auto-dev"

Option "HorizScrollDelta" "0"

EndSection

Section "Device"

Identifier "ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200 (AGP)]"

Driver "ati"

BusID "PCI:1:5:0"

Option "UseFBDev" "true"

EndSection

Section "Monitor"

Identifier "Monitor Generico"

Option "DPMS"

HorizSync 28-64

VertRefresh 43-60

EndSection

Section "Screen"

Identifier "Default Screen"

Device "ATI Technologies Inc M9+ 5C61 [Radeon Mobility 9200 (AGP)]"

Monitor "Monitor Generico"

DefaultDepth 24

SubSection "Display"

Modes "1280x800"

EndSubSection

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

InputDevice "Synaptics Touchpad"

EndSection



Quando carico GNOME in locale, la configurazione della tastiera e`

http://img504.imageshack.us/img504/5991/impostazionetastieragnodb5.th.jpg (http://img504.imageshack.us/my.php?image=impostazionetastieragnodb5.jpg)

Mentre, quando lo carico su un display X remoto, tale configurazione diventa

http://img405.imageshack.us/img405/2794/impostazioneremotatastikj6.th.jpg (http://img405.imageshack.us/my.php?image=impostazioneremotatastikj6.jpg)

Per la cronaca, ho provato ad avviare il server x11vnc sul Server con il seguente comando /usr/bin/x11vnc -inetd -rfbport 5901 -rfbauth /home/balubeto/.vnc/passwd -create -capslock -forever o con il comando /usr/bin/x11vnc -inetd -rfbport 5901 -rfbauth /home/balubeto/.vnc/passwd -create -forever ma non cambia nulla. Invece, sulla macchina Windows XP ho il viewer TightVNC.

GRAZIE

CIAO