PDA

Visualizza versione completa : [HTML] Layout pagina che crea problemi a IE7


Alhazred
13-03-2008, 12.50.35
Ho un paio di problemi con il layout che uso su un myspace.
IE7 occupa la CPU al 100% col layout che ho inserito causando ovviamente un rallentamento totale nella visualizzazione, se metto il layout standard (eliminando tutto il codice del layout che posto qui sotto) invece l'occupazione della CPU non supera il 40% e tutto va a meraviglia.
Un problema ce l'ha anche FF, va bene con il layout che ho impostato io, ma crolla nelle prestazioni se aggiungo un po' di trasparenza alle tabelle dandomi lo stesso problema di IE7.

Questo è il codice del layout che uso, trovate qualcosa che possa dare problemi a IE7 in termini di risorse richieste?

<style>
body.bodyContent {
background-color: rgb(0, 0, 0);
background-image: url(http://img178.imageshack.us/img178/6079/dragon3ro9.jpg);
background-position: top left;
background-repeat: repeat;
background-attachment: fixed;
}
table, tr, td {
background-color: transparent;
border: 1px;
}

table table {
border: 1px;
}
table table table table{
border: 1px;
}
table table table {
border-width: 1px;
border-color: rgb(255, 255, 0);
border-style: dashed;
background-color: rgb(0, 0, 0);
}
table table,table table table table,table table table td {
filter:alpha(100);
-moz-opacity: 1;
opacity: 1;
-khtml-opacity: 1;
}
table table table table td {
filter:none;
}

General,body,div,p,strong,td,textarea,input,.text, span.redtext,span.redbtext,span.blacktext10,span.b lacktext12 {
font-family: Verdana;
font-size: 12px;
color: rgb(255, 255, 0);
font-weight: bold;
font-style: normal;
text-decoration: none;
}
.nametext {
padding: 5px;
font-family: Georgia;
font-size: 20px;
color: rgb(255, 255, 0);
font-weight: bold;
font-style: italic;
text-decoration: none;
display: block;
}
.whitetext12, .orangetext15 {
font-family: Verdana;
font-size: 12px;
color: rgb(255, 255, 0);
font-weight: normal;
font-style: normal;
text-decoration: none;
}
AllLinksNormal,a,a:link,a:visited,a.man,a.man:link ,a.man:visited,a.navbar,a.navbar:link,a.navbar:vis ited,a.redlink,a.redlink:link,a.redlink:visited,a. searchlinkSmall,a.searchlinkSmall:link,a.searchlin kSmall:visited,a:hover,a:active,a.man:hover,a.man: active,a.navbar:hover,a.navbar:active,a.redlink:ho ver,a.redlink:active,a.searchlinkSmall:hover,a.sea rchlinkSmall:active {
color: rgb(255, 255, 255);
font-weight: bold;
font-style: normal;
text-decoration: none;
}
AllLinksHover,a:hover,a:active,a.man:hover,a.man:a ctive,a.navbar:hover,a.navbar:active,a.redlink:hov er,a.redlink:active,a.searchlinkSmall:hover,a.sear chlinkSmall:active {
color: rgb(255, 0, 0);
font-weight: bold;
font-style: normal;
text-decoration: underline;
}
.badge {
position: absolute;
left: 1px;
top: 1px;
}

</style>
Se volete dare un'occhiata per vedere cosa succede...
Edit: link rimosso.

RNicoletto
13-03-2008, 16.54.39
Ti ho risposto qui (http://forum.wintricks.it/showthread.php?p=1471455#post1471455). :)

Sergio Neddi
13-03-2008, 16.55.30
Ehm... non per rompere le scatole, ma come da regolamento:

http://forum.wintricks.it/regolamento.html

link a siti personali solo nella signature, grazie!

Alhazred
13-03-2008, 17.11.34
Sorry, conosco il regolamento in materia di link a siti personali, ma non era per pubblicità, per quello l'ho messo... edito e rispondo nel thread linkato da RNicoletto..