PDA

Visualizza versione completa : [EXCEL] problema con DataBase


sensualman
24-02-2008, 19.10.12
Domanda: Ho una lista clienti e un Database (quindi 2 fogli). Vorrei verificare quali di questi sono presenti o meno nel DataBase e se Ŕ presente copiarlo in fondo all'elenco della lista clienti, qualcuno riesce ad aiutarmi?
--------------------------------------------
Ho iniziato il lavoro ma non riesco ad ottenere il risultato che vorrei:
Utilizzando la funzione CERCA.VERT in questo modo.
Diciamo che il database dei clienti si trova nel foglio DB nella colonna A e l'elenco dei clienti si trova nella colonna A del foglio di lavoro corrente a partire dalla cella A2.
Nella cella B2 del foglio di lavoro corrente, ho inserito la seguente formula:

=SE(VAL.NON.DISP(CERCA.VERT(A2;DB!A:A;1;0));"NON PRESENTE";"PRESENTE")

la formula attraverso un CERCA.VERT verifica nella lista in DB l'esistenza del cliente. Se il codice esiste allora CERCA.VERT lo restituisce e dunque non restituisce un errore. In questo caso VAL.NON.DISP risulta FALSO e viene allora scritto PRESENTE. Nel caso in cui il cliente non sia presente in DB allora il CERCA.VERT restituisce un errore, VAL.NON.DISP rileva l'errore e dunque viene stampato NON PRESENTE.
In realtÓ dovrei far in modo che se il valore Ŕ presente nel DataBase, lo copi automaticamente nell'ultima riga dell'elenco clienti.
Qualcuno riesce ad aiutarmi?