PDA

Visualizza versione completa : Rete LAN e rilevamenti risorse


TH3WiZ@RD
28-01-2008, 10.02.37
Non avete mai avuto problemi di rilevamento delle risorse in rete...?

ossia:

2 comuter con windows xp pro
un router /switch che gestisce automaticamente i DHCP

eppure quando provo ad andare a cercare risorse di rete condivise, pur avendole condvise, si blocca, o non mi trova nulla ect ect ect.....

vi dico questo perchè capita anche ad altri miei amici

il problema non dipende da AV perchè loro non ne hanno e non si risolve ne configurando manualmente gli indirizzi, ne utilizzando cavi incrociati.


a volte va a volte no....

AMIGA
28-01-2008, 21.46.22
Prova a disattivare il Firewall,molti bloccano la comunicazione in rete,in particolare quelli messi dagli antivirus.
Per facilitare la connessione Stesso Gruppo di Lavoro,Nomi utenti Uguali (così non chiederà nome utente e password).Il nome dei Computer non devono essere uguali altrimenti la rete non funziona (arriverà messaggio Nome Computer già presente in rete). Altra cosa se il cavo è crociato controlla gli Indirizzi IP che siano uguali con solo la quarta cifra diversa. Per i cavi standard invece possono stare con indirizzo automatico.Per cercare velocemente un PC anzichè cercare nella rete,puoi usare una scorciatoia aprendo una qualsiasi cartella e sulla barra degli indirizzi digitare \\nome comuter,se cerchi un computer di nome pippo dovrai scrivere \\pippo

TH3WiZ@RD
29-01-2008, 09.28.14
Quella della scorciatoia non la sapevo, per il resto, avevo già provato tutto, ma nulla da fare, i computer si pingano a vicenda ma da un pc non si può accedere alle risorse dell'altro benchè siano condivise.....

utilizzano un programma esterno sono riuscito comuqnue ad accedere ma mi rode sapere che windows da solo non è in grado di farlo, non dovrebbe essere così.....

LoryOne
29-01-2008, 14.41.52
Pingare sull' IP significa verificare solo la connettività ed il routing
In pratica non significa nulla se non verificare che giungeranno successivamente pacchetti con protocollo e payload (di fatto un servizio) al client di test.

Verifica che tu abbia abilitato i due servizi:
Workstation (Di fatto il gestore di NetBIOS)
Server (Di fatto il gestore delle connessioni)

Verifica che netstat -aon ti fornisca i seguenti protocolli e porte in ascolto
UDP 137 e 138: Enumerazione rete LAN e nomi NetBIOS
TCP 139 e 445: SMB per la gestione delle condivisioni risorse

I kernel basati su NT utilizzano prima la 445 e poi la 139.
I kernel 9x solo la 139 (considerate eventualmente anche la 135 per la coda si stampa)
(E' buona norma mantenere la 139 solo sui sistemi misti NT/9x. Mantenere la 139 anche sui kernel NT non è male, purchè la blocchiate sul perimetro esterno (il vostro router), visto che la maggior parte dei software obsoleti di enumerazione (ma ancor validi per molti lamer) è proprio su questa porta che vengono eseguiti. Ricordate che se siete admin della vostra rete possono esservi utili, quindi evitate solo dall'esterno che qualcuno possa farne uso.)

Telnetta su IP e porta 139
Se avviene la connessione:
- non esiste firewall
- non esiste filtro su scheda client
- non esiste filtraggio di IP/protocollo sul router

Utilizza net view \\IP e verifica le periferiche condivise
Se le vedi
- è tutto OK,
Se non le vedi
- la porta SMB può essere aperta, ma può non esistere alcuna periferica di rete associata a tale servizio che di fatto è in ascolto ma non è in funzione.
Effettua una ricerca sul forum ... Argomento già trattato.

Spesso bastano queste dritte.
Tu intanto verifica, poi ci saprai dire ... ;)

TH3WiZ@RD
29-01-2008, 15.00.03
ok grazie appena avrò un attimo di tempo verificherò