PDA

Visualizza versione completa : [LINUX] xorg: device not found


xavierLoS
20-11-2007, 08.35.54
Ciao a tutti,

ho un problema mettendo le mani su un hp pavillion dv6640el, ho ripartizionato l'area di hdd destinata a win vista per installare la debian.

L'installazione parte, durante il processo mi chiede di caricare il modulo per il floppy disk e di dare dei parametri per la scheda pcmcia e non mi riconosce la scheda ethernet, ma superati questi punti l'installazione va a buon fine..

riavvio la macchina, fatto tutto il processo di caricamento si inizia a caricare lo gnome, ci prova una volta, due volte, alla terza mi vien fuori una scritta con il server grafico non stato possibile caricarlo..

e mi mostra il login in ambiente di console.

ora ho provato a:
- modificare /etc/X11/xorg.conf
- lanciare dpkg-reconfigure xserver-xorg
- ad avviare il pc con un live CD ubuntu, kubuntu (ma stesso errore)

ma l'errore sempre device not found!!

io ho scaricato ed installato i dvd per x86, il pc un AMD thurion X64

grazie mille
ale :)

Ghandalf
20-11-2007, 13.26.17
Bisognerebbe dare un'cchiata al log del server grafico.

:)

xavierLoS
20-11-2007, 17.41.59
come si fa a vedere il log del server grafico??

vuoi anche il mio xorg.conf??

ma possibile che un pc non sia compatibile con linux??

xavierLoS
21-11-2007, 08.38.25
ieri ho fatto diverse prove, ho reinstallato anche una fedora ..
ma l'installazione va alla perfezione, mi tira su la grafica al riavvio che non mi riconosce nessun dispositivo hardware, e non so che cosa prendere..

comunuque qui ho:


lspci

00:00.0 RAM memory: nVidia Corporation Unknown device 0547 (rev a2)
00:01.0 ISA bridge: nVidia Corporation Unknown device 0548 (rev a2)
00:01.1 SMBus: nVidia Corporation Unknown device 0542 (rev a2)
00:01.2 RAM memory: nVidia Corporation Unknown device 0541 (rev a2)
00:01.3 Co-processor: nVidia Corporation Unknown device 0543 (rev a2)
00:02.0 USB Controller: nVidia Corporation Unknown device 055e (rev a2)
00:02.1 USB Controller: nVidia Corporation Unknown device 055f (rev a2)
00:04.0 USB Controller: nVidia Corporation Unknown device 055e (rev a2)
00:04.1 USB Controller: nVidia Corporation Unknown device 055f (rev a2)
00:06.0 IDE interface: nVidia Corporation Unknown device 0560 (rev a1)
00:07.0 Audio device: nVidia Corporation Unknown device 055c (rev a1)
00:08.0 PCI bridge: nVidia Corporation Unknown device 0561 (rev a2)
00:09.0 IDE interface: nVidia Corporation Unknown device 0550 (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation Unknown device 054c (rev a2)
00:0c.0 PCI bridge: nVidia Corporation Unknown device 0563 (rev a2)
00:0d.0 PCI bridge: nVidia Corporation Unknown device 0563 (rev a2)
00:12.0 VGA compatible controller: nVidia Corporation Unknown device 0531 (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:05.0 FireWire (IEEE 1394): Ricoh Co Ltd Unknown device 0832 (rev 05)
02:05.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
02:05.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 12)
02:05.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
02:05.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
03:00.0 Network controller: Broadcom Corporation Unknown device 4328 (rev 03)


lspci-n

00:00.0 0500: 10de:0547 (rev a2)
00:01.0 0601: 10de:0548 (rev a2)
00:01.1 0c05: 10de:0542 (rev a2)
00:01.2 0500: 10de:0541 (rev a2)
00:01.3 0b40: 10de:0543 (rev a2)
00:02.0 0c03: 10de:055e (rev a2)
00:02.1 0c03: 10de:055f (rev a2)
00:04.0 0c03: 10de:055e (rev a2)
00:04.1 0c03: 10de:055f (rev a2)
00:06.0 0101: 10de:0560 (rev a1)
00:07.0 0403: 10de:055c (rev a1)
00:08.0 0604: 10de:0561 (rev a2)
00:09.0 0101: 10de:0550 (rev a2)
00:0a.0 0200: 10de:054c (rev a2)
00:0c.0 0604: 10de:0563 (rev a2)
00:0d.0 0604: 10de:0563 (rev a2)
00:12.0 0300: 10de:0531 (rev a2)
00:18.0 0600: 1022:1100
00:18.1 0600: 1022:1101
00:18.2 0600: 1022:1102
00:18.3 0600: 1022:1103
02:05.0 0c00: 1180:0832 (rev 05)
02:05.1 0805: 1180:0822 (rev 22)
02:05.2 0880: 1180:0843 (rev 12)
02:05.3 0880: 1180:0592 (rev 12)
02:05.4 0880: 1180:0852 (rev 12)
03:00.0 0280: 14e4:4328 (rev 03)



ringrazio anticipatamente per l'aiuto..
ale

xavierLoS
21-11-2007, 08.39.09
qui:

xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "nVidia Corporation NVIDIA Default Card"
Driver "nv"
BusID "PCI:0:18:0"
EndSection

Section "Monitor"
Identifier "Monitor Generico"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NVIDIA Default Card"
Monitor "Monitor Generico"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Alhazred
21-11-2007, 12.58.16
...
io ho scaricato ed installato i dvd per x86, il pc un AMD thurion X64
...

Io sono nuovo di linux, la prima avvertenza che mi stata data stata questa: hai un Athlon64, quindi DEVI scaricare la versione di linux per processori a 64 bit.

Ghandalf
21-11-2007, 13.19.25
Io sono nuovo di linux, la prima avvertenza che mi stata data stata questa: hai un Athlon64, quindi DEVI scaricare la versione di linux per processori a 64 bit.


mmm...non so, io ho utilizzato senza problemi il classico X86 su architetture a 64. Il devi mi pare po' estremo, puoi, visto che tutti i pacchetti principali hanno il supporto per i 64bit.

Per i log del server grafico posta il contenuto di:

/var/log/Xorg.0.log

o qualcosa di simile.

:)

xavierLoS
22-11-2007, 08.44.14
Ragazzi sono riuscito.. sono riuscito.. sono riuscito..

il procedimento questo :

scaricato da qui: http://kmuto.jp/debian/d-i/ l'immagine editata con gli ultimi driver del sistema base (io ho tirato gi la AMD)

avviato l'installer con quella, nessun problema ma mi ha scaricato solo il sistema base

allora inserito il cd rom completo montato e fatto apt-cdrom -m add

poi ho installato gnome e xservr

da console digitato startx

gnome funziona!!!


seguendo il link, non riesco ad installare i driver per la nvidia come dice questa guida: http://pvlug.helloweb.eu/forum/index.php?topic=37.0
perch il mio pc mi tira ora solo a 1024x768

p.s. mi riconosce anche la scheda ethernet!! yatta!!!


ciao ciao
ale


grazie di tutto