PDA

Visualizza versione completa : [LINUX] errore lilo 99


agimar
26-10-2007, 11.55.25
Buon giorno a tutti,
un amico vorrebbe linux sul suo pc, dopo che ha visto che io lo uso intensamente (ho installato Mandriva 2007).
15 giorni fa mi porta il suo PC, installo Paragon Partition e creo una partizione linux extension 3 ed una di swap, nell'ultima parte dell'HD. Installo linux e indico nel Floppy la destinazione del lilo boot. Terminate le operazioni di installazione riavvio, ma il systema non parte da floppy e mi restituisce l'errore L 99 (99 99 ...).
Penso che sia il floppy, lo sostituisco, reinstallo linux ed il lilo boot sul floppy nuovo: stesso errore, allora installo (sempre su floppy) GRUB che NON parte e mi da errore: GRUB 18.
Allora decido di installare il lilo sull' mbr del disco C: Prima con lilo e poi con grub. Stesso errore.
Allora riformatto la partizione di linux e decido di installare SUSE, l'installazione procede bene e termina, come sempre, con la fatidica frase: Suse correttamente installato, togli il DVD e riavvia.
Stesso identico errore di prima sia con LILO che con Grub e sia con floppy, che con MBR.
Faccio partire il PC da CD con una versione live di Mandriva 2008 ONE, parte regolarmente e provo qualche applicazione. Tutto funziona bene (con le limitazioni che derivano dalla versione live!)
Un opzione mi dice che se voglio installare Mandriva One sull'hd lo posso fare. Faccio partire l'installazione e installo ONE nella partizione linux creata precedentemente con Paragon Partition.
Tutto regolare... mi chiede dove desidero configurare il boot. Faccio
tre tentativi, sul floppy, sull'MBR e sulla partizione in cui installato
linux (hdb8), ma NULLA! Medesimo errore. Linux installato, ma non so farlo
partire. Con un'utility dal nome explore2fs-1.08beta9.exe da ambiente WinXP sono andato a visualizzare il contenuto di Linux ed ho estratto il file LILO.conf in /etc/ che riporto qui sotto (qualora potesse servire a risolvere il problema):

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="linux"
boot=/dev/hda
map=/boot/map
keytable=/boot/it-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda8
initrd=/boot/initrd.img
append="devfs=nomount acpi=ht resume=/dev/hda9 splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda8
initrd=/boot/initrd.img
append="devfs=nomount acpi=ht resume=/dev/hda9 splash=silent"
read-only
other=/dev/hda1
label="windows"
table=/dev/hda
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda8
initrd=/boot/initrd.img
append="failsafe acpi=ht resume=/dev/hda9 splash=silent devfs=nomount"
read-only

In sostanza, la mia domanda :
come posso installare lilo (o grub) su un floppy in modo che all'avvio mi possa far partire linux?

Grazie.
agimar

UG0_BOSS
26-10-2007, 20.19.24
Girando qua e l su internet (link (http://www.debianitalia.org/modules/newbb/viewtopic.php?viewmode=flat&topic_id=512&forum=1#5)) pare che un modo per risolvere la faccenda sia di creare una partizione di boot (da montare in /boot) all'inizio del disco: ci installi GRUB o LiLo e conterr quindi kernel, initrd e la configurazione del boot loader.

agimar
26-10-2007, 22.45.44
Grazie Ugo_Boss, il tuo link stato molto utile... Ho cercato tanto in internet, ma quel 3D indicato da te non l'avevo letto. Non mi risolve il problema, ma mi orienta verso il BIOS, a cui avevo gi pensato anche io. Io non posso creare una partizione all'inizio dell'HD perch l c' Windows e non mi permetto di toccare visto che non il mio PC. Potrei mettere per un secondo HD ed installare linux l... Ora ci penso, ma quello che mi fa strano neanche con LILO il mio sistema parta, mentre quello del "nuovo utente" si avvia con LILO e non con GRUB. Grazie ancora!
agimar

agimar
29-10-2007, 23.45.48
Caro Ugo_Boss, ho risolto il problema grazie al tuo intervento e al link che mi hai indicato. Era un broblema di Bios e di dimensione dell'HDisk (160 giga). Ho risolto cos: ho messo un HD da 20 giga sul secondario master e l ho installato linux. ha funzionato subito sia il LILO che il GRUB, sia da boot da floppy che da HD.
Quindi... Grazie!
agimar