PDA

Visualizza versione completa : [XP PRO SP 2]non si installa aggiornamento kb 939373 appena uscito...


cippico
14-07-2007, 00.29.06
appare msg di errore su mancanza componente...ora non ricordo bene la dicitura...

e' capitato a qualcun altro?

le varie patch correttive di sicurezza sono state sempre aggiornate...

tenete conto che sul pc non e' installato netframework...magari e' un componente che ha a che fare con questa patch...

grazie a tutti e ciaooo

Lionsquid
14-07-2007, 01.40.08
fatto tutti gli aggiornamenti, ho il netframework 2.0 e nessun errore


la tua riflessione potrebbe essere corretta...

aspettiamo qualche altro feedback ;)

leofelix
14-07-2007, 01.46.49
Come da titolo, in un sistema XP PRO SP2, qualcosa di simile è accaduto anche a me due sere fa. Si trattava in un aggiornamento al Microsoft .NET Framework 1.1 che in ogni caso non utilizzo.
Così l'ho disinstallato e ho "chiesto" alla MS gentilmente di non farmelo più visualizzare durante "Microsoft update".

Poi ho scoperto che la MS ha ideato apposito per una disinstallazione pulita di queste componenti NET Framework :wall:

Ma il tuo problema mi sembra diverso e sembra relativo agli Internet Information Services.
Ho trovato questa pagina in merito:

http://support.microsoft.com/kb/939373


Spero ti possa essere utile, per quanto possano essere chiare le spiegazioni che forniscono

esdisu
14-07-2007, 15.17.05
fatto tutti gli aggiornamenti, ho il netframework 2.0 e nessun errore


la tua riflessione potrebbe essere corretta...

aspettiamo qualche altro feedback ;)
A me è appena successo con il NET(2,0)KB 928365 , non si istalla , segnalato puntualmente dal visualizzatore eventi , siccome possiedo il NET 3 , se disinstallo il NET 2 le applicazioni che richiedono il 2 funzionano ciononostante ? :mm: :)

leofelix
14-07-2007, 19.01.08
A me è appena successo con il NET(2,0)KB 928365 , non si istalla , segnalato puntualmente dal visualizzatore eventi , siccome possiedo il NET 3 , se disinstallo il NET 2 le applicazioni che richiedono il 2 funzionano ciononostante ? :mm: :)

Non saprei ad onor del vero, in ogni caso si potrebbe tentare con questa soluzione, che ho trovato dopo "indefesse" ricerche sul web :inn:

1. Scaricare il Microsoft Installer Clean Up Tool (in Inglese) da:

http://download.microsoft.com/download/e/9/d/e9d80355-7ab4-45b8-80e8-983a48d5e1bd/msicuu2.exe

2. Lanciare l'installazione guidata che decomprime ed avvia il Microsoft’s Uninstaller.

3. Nel Menu Start sarà presente una nuova applicazione installata e chiamata “Windows Install Clean Up”.

4. Lanciare “Windows Install Clean Up”, selezionare Microsoft Framework 1.1 e 2.0, quindi selezionare “Rimuovi”.

5. Raggiungere la directory C:/Windows e rinominare la cartella Microsoft.Net (ad esempio in “Microsoft.Net.Old”)

NOTA: Internet Explorer e qualunque applicazione che utilizza Microsoft.NET DEVE essere chiusa.

6. Riavviare il computer (Operazione Indispensabile)
7. scaricare tramite dal sito Microsoft SOLO le versioni di Microsoft Framework che interessano.
8. Procedere con l'installazione della versione di Microsoft Framework che interessa.

Ulteriori precauzioni (basate su miei fondati sospetti)

WARNING: Se si utilizzano un firewall, un antivirus o un antispyware che bloccano il file HOST, proteggono Internet Explorer sia impedendo l'esecuzione di script sia impedendo l'installazione di BHO, toolbar, controlli ActiveX, disabilitare temporaneamente le protezioni su indicate per il tempo necessario, prima di effettuare le procedure su indicate
NB Ho letto che per esempio alcune versioni di Zonealarm possono impedire la corretta installazione del Net. Framework se non configurate adeguatamente.


------
Insomma io alla fine ho risolto in questo modo alla fine nel sistema XP PRO in cui si è verificato il problema, ma ci non metterei le mani sul fuoco che questa soluzione vada bene per tutti.

Ciau:)

altre info qui:
http://support.microsoft.com/kb/290301

esdisu
14-07-2007, 19.24.11
(Y) Grazie. :)

leofelix
14-07-2007, 19.38.01
(Y) Grazie. :)

prego, come avrai notato la mia probabile soluzione è stata soprattutto frutto di uno "splendido" copia e incolla della mia ricerca.. esclusa la parte finale:-)

leofelix
14-07-2007, 21.59.42
ehm forse avevo messo un link che non andava bene per quella utility, ho corretto poco fa il mio post precedente aggiungendo l'articolo relativo della KB della Microsoft.

Scusate, procedo con l'autoflagellazione

esdisu
15-07-2007, 10.51.44
Non sei rimasto molto soddisfatto della rimozione che hai fatto del NET 1.1 dal pannello di controllo aggiungi/rimuovi dato che mi consigli il CleanUp , qualcosa non ha funzionato ?
Per istallare la 3 ho usato il dotnetx3setup e tutto è andato a meraviglia , linguaggio italiano ecc.ecc. unico neo il Cardspace , ma fa parte del pacchetto (che rogna).

leofelix
15-07-2007, 17.06.45
In realtà sembrava che la disinstallazione non fosse avvenuta correttamente da pannello di controllo visto che continuavo a visualizzare proprio il Net. Framework 1.1 e relativi aggiornamenti come installati in "aggiungi/rimuovi".

Mi è successo altre volte anche in passato con altri programmi e con altre versioni di Windows.

Così ho usato alla fine ho usato quella utily.

Le altre versioni di NET.Framework e relativi aggiornamenti le ho sempre installate direttamente via "Microsoftupdate".

Presumo che qualche file fosse corrotto, oppure - cosa ancora più probabile - ho fatto qualche minchiata io :wall:

cippico
15-07-2007, 17.38.40
Come da titolo, in un sistema XP PRO SP2, qualcosa di simile è accaduto anche a me due sere fa. Si trattava in un aggiornamento al Microsoft .NET Framework 1.1 che in ogni caso non utilizzo.
Così l'ho disinstallato e ho "chiesto" alla MS gentilmente di non farmelo più visualizzare durante "Microsoft update".

Poi ho scoperto che la MS ha ideato apposito per una disinstallazione pulita di queste componenti NET Framework :wall:

Ma il tuo problema mi sembra diverso e sembra relativo agli Internet Information Services.
Ho trovato questa pagina in merito:

http://support.microsoft.com/kb/939373


Spero ti possa essere utile, per quanto possano essere chiare le spiegazioni che forniscono

l'url spiega tutto...cmq riporto tutto...

Problema noto a questo aggiornamento per la protezione
Internet Information Services ( IIS ) 5,1 è un componente facoltativo in Microsoft Windows XP Professional Service Pack 2 (SP2). Windows Update offre questo aggiornamento per la protezione se il componente IIS 5.1 solo si installa nel computer.

Se si scarica questo aggiornamento dall'Area download Microsoft per la protezione e se si tenta manualmente di installare questo aggiornamento su un computer Windows XP Professional SP2-based che non dispone del componente IIS 5.1 per la protezione, si visualizza un messaggio di errore. Questo messaggio di errore indica che un prerequisiti è che manca e che non si installerà l'aggiornamento per la protezione. Questo comportamento è visto.

Disattivare tutti i messaggi è possibile utilizzando l'opzione /quiet.

Gli amministratori dovrebbero utilizzare uno dei metodi supportati per verificare che l'installazione sia terminata quando esse utilizzano il parametro /quiet. Si dovrebbero prevedere gli amministratori che ricevono i messaggi di errore nel file Kb939373.log quando non si installa il componente IIS 5.1.

grazie x la segnalazione...infatti io il componente facoltativo non ce l'ho...cosi' come NET.Framework...

grazie e ciaooo

leofelix
15-07-2007, 18.49.47
prego,
adoro trovare le soluzioni più complesse.. specie quando di fatto alla fine si rivelano superflue se non inutili, come in questo caso:-)

cippico
16-07-2007, 07.42.00
prego,
adoro trovare le soluzioni più complesse.. specie quando di fatto alla fine si rivelano superflue se non inutili, come in questo caso:-)

:act: ;)

ciaooo

esdisu
16-07-2007, 14.36.17
Anche a me non si istalla la 939373 :wall: , mi rimanda a leggere il .log in Windows , dopo due righe li mando a quel paese :inkaz: , mi viene sempre in mente ciò che un giorno disse twentek : io ho XP e Vista , mai fatto aggiornamenti , mai istallato service pack , i miei PC vanno come un razzo ... :dance: , alla faccia di chi si aggiorna :devil: :w:

esdisu
17-07-2007, 18.38.04
Cippico , :) , che facciamo ?Ci diamo una "pacca" sulle spalle e rinunciamo alle pack ? :D

cippico
17-07-2007, 18.57.19
Cippico , :) , che facciamo ?Ci diamo una "pacca" sulle spalle e rinunciamo alle pack ? :D

alla fine...da quello che ho capito...se non si ha Microsoft .NET Framework la patch non necessita...in quanto il problema non esiste visto che l'applicazione non risiede sul pc...

ciaooo

leofelix
17-07-2007, 19.32.27
alla fine...da quello che ho capito...se non si ha Microsoft .NET Framework la patch non necessita...in quanto il problema non esiste visto che l'applicazione non risiede sul pc...

ciaooo

appunto, ma se vuoi utilizzare delle applicazioni che necessitano il NET.Framework, devi installarlo (lapalissiano, lo so)...

Tutto questo mi ricorda il celeberrimo COMMA 22 di J. Heller

"Chi è pazzo può chiedere di non installare le patch Microsoft, ma chi chiede di installare le Patch Microsoft è pazzo":-)

x esdisu:

Se Le patch Microsoft sono "cerotti", i Service Pack, sono dei "pacchi"?;)

esdisu
17-07-2007, 20.01.11
:act: , per cippico : sei obsoleto non hai il NET.tare (vedi le api ;) ) non quelle del PC :devil: , le api , api :01:

cippico
18-07-2007, 07.45.32
:act: , per cippico : sei obsoleto non hai il NET.tare (vedi le api ;) ) non quelle del PC :devil: , le api , api :01:

non avendo nessun prg a cui serve il paccone installato...finche´posso...non lo installero´... ;)

ciaooo

esdisu
18-07-2007, 08.24.41
non avendo nessun prg a cui serve il paccone installato...finche´posso...non lo installero´... ;)

ciaooo
E fai bene , hai minori grattacapi da risolvere. :wall:

cippico
18-07-2007, 14.54.29
E fai bene , hai minori grattacapi da risolvere. :wall:

qualche volta ho visto dei prg interessanti...che volevano appunto il paccone installato...ma ho resistito... :inn:

ciaooo

esdisu
18-07-2007, 19.00.02
Erase temp.