PDA

Visualizza versione completa : Sommare caselle excel contrassegnate di un elenco


ghisirds
02-07-2007, 21.35.06
Salve.
Mi sto scervellando per cercare di capire come risolvere questo problema.
Ho un elenco di nomi in colonna A con a fianco alcune X in colonna B

A B
1 Casa X
2 Auto
3 Casa X
4 Fiori
5 Orologio
6 Casa X
7 Fiori
8 Casa

Col passare del tempo vengono inseriti dei nomi nuovi in colonna A e alcune X in colonna B.
Allora, io dovrei creare una formula da mettere in questo caso in B8 che poi viene trascinata in tutte le celle della colonna B, che controlla la cella a fianco della stessa riga (in questo caso la A8) quante volte Ŕ presente nell'elenco, ma solo nel caso in cui vi Ŕ la X nella riga corrispondete.
Quindi, in questo caso in B8 ci deve venir scritto 3, in B7 scritto 0 ecc.

Contare tutte le volte che compare la parola affiancata dalla X: non dovrebbe essere una formula complicata, ma non ci salto fuori..

Grazie in anticipo a chiunque mi aiuterÓ.

Alexsandra
03-07-2007, 11.14.51
Con le formule non sono tanto afferrata, comunque prova:

=MATR.SOMMA.PRODOTTO(--($A$1:$A$7=A8);--($B$1:$B$7="X"))