PDA

Visualizza versione completa : [errore] Impossibile avviare il servizio Registro Eventi


Alexander_22
02-07-2007, 12.58.00
Ciao ragazzi,

ho un problema con Vista. Ci sono infatti alcuni servizi che non riesco ad avviare, tra cui c'è il Servizio Registro Eventi. Ho provato ad avviare il servizio sia dai Servizi, sia da prompt. Il messaggio che mi viene restituito è:



Impossibile avviare il servizio registro eventi di Windows su computer locale.

Errore2: Impossibile trovare il file specificato.



Ho provato con il controllo delle dll di Windows con sfc /scannow ma non ho ottenuto nessun risultato.



Idee??

Grazie..

giancarlof
02-07-2007, 16.52.45
Ciao ragazzi,

ho un problema con Vista. Ci sono infatti alcuni servizi che non riesco ad avviare, tra cui c'è il Servizio Registro Eventi. Ho provato ad avviare il servizio sia dai Servizi, sia da prompt. Il messaggio che mi viene restituito è:



Impossibile avviare il servizio registro eventi di Windows su computer locale.

Errore2: Impossibile trovare il file specificato.




Ho provato con il controllo delle dll di Windows con sfc /scannow ma non ho ottenuto nessun risultato.



Idee??

Grazie..

Non scrivi il sistema operativo installato spero che sia Windows XP, vedi questo workaround non saltare passaggi:

http://giancarlof-giancarlo.blogspot.com/search?q=ripristinare+registro+eventi

real7
02-07-2007, 19.39.48
Non scrivi il sistema operativo installato spero che sia Windows XP, vedi questo workaround non saltare passaggi:

http://giancarlof-giancarlo.blogspot.com/search?q=ripristinare+registro+eventi
veramente ha scritto :
"ho un problema con Vista"
ogni tanto capita ;)

real7
02-07-2007, 19.46.55
prova se si apre tramite Esegui , digitare
eventwr

giancarlof
03-07-2007, 03.12.31
veramente ha scritto :
"ho un problema con Vista"
ogni tanto capita ;)


Hai ragione capita ;) come in questo caso che però non è una tua svista, dove consigli due programmi per rispristinare un avvio fra XP e Vista dopo l'installazione di Windows XP su un Vista già installato. Ti dirò che che sempre in questi casi si ha una sovrascrizione di MBR (Master Boot Record) e che quindi i due programmi segnalati non possono fare nulla perchè agiscono un altro modo e soltanto su un dual boot già esistente e non ricreandolo dove era sovrascritto. D'altra parte che sovrascriva il MBR è cosa nota a tutta la rete ed io infatti l'ho imparato leggendo e per quello avevo fatto il tip che ho consigliato nella discusssione. (ot)

http://www.wintricks.it/forum/showpost.php?p=1335042&postcount=22

----------------------------------------------------------------
1) Installare Windows Xp (sovrascriverà il mbr di Vista)

http://www.twitter.it/blog/?p=26
----------------------------------------------------------------

@ Alexander
Segui pure esattamente il tip che ti ho scritto sopra vediamo.

Alexander_22
09-07-2007, 13.54.55
@ Alexander
Segui pure esattamente il tip che ti ho scritto sopra vediamo.

Ho seguito quanto scritto nel tuo link ma evidentemente non coincide con Windows Vista perchè non c'erano i file menzionati nel post. Tuttavia il problema non è nel visualizzatore eventi ma nel servizio Visualizzatore Eventi. Cioè: il servizio è impostato su avvio automatico ma all'avvio del pc il Servizio non parte e di conseguenza aprendo il visualizzatore eventi mi avverte che il servizio non è avviato. Se tento di avviarlo manualmente mi dà l'errore descritto in fase di apertura del post.

giancarlof
09-07-2007, 14.12.21
Editato fuori argomento.

Alexander_22
09-07-2007, 15.10.43
Dici che non coincide vedi quanti sono che usano la metodica falla con attenzione e vedrai che è il modo per riparare il tuo avvio:

http://blogs.dotnethell.it/michelen/Windows-Vista-BootMenu__9710.aspx


http://www.twitter.it/blog/?p=26

Addirittura viene consigliata da Microsoft che immagino sappia quello che scrive sul suo sistema operativo.

http://support.microsoft.com/kb/919529/it

Aspetta! Forse mi sto rimbecillendo io ma i link che mi hai mandato riguardano il dual boot.

giancarlof
09-07-2007, 15.23.54
Aspetta! Forse mi sto rimbecillendo io ma i link che mi hai mandato riguardano il dual boot.

Nulla da dire se non che hai perfettamente ragione, io continuavo a rispondere a un'altra cosa che non c'entra nulla con il tuo problema. Vediamo meglio:
vai nei servizi e apri la finestra cliccando sul registro eventi, fra l'altro ho visto che ti da errore 2, in quella finestra vai sulla tab DIPENDENZE e leggi da cosa dipende questo servizio vai sui servizi corrispondenti ed avviali se danno un errore riporta tutto numero compreso.

Alexander_22
09-07-2007, 16.02.47
Nulla da dire se non che hai perfettamente ragione, io continuavo a rispondere a un'altra cosa che non c'entra nulla con il tuo problema.

Ah ecco! Mi stavo già preoccupando per la mia salute psichica. :) Tranquillo comunque.

Tornando a noi il servizio Registro Eventi non dipende da nessun altro servizio ma ne ha 2 che dipendono da lui:

1 Servizio Messenger Sharing Folders USN Journal Reader;
2 Utilità di Pianificazione;

Questi due servizi risultano non avviati e dipendono dal servizio Registro Eventi e dal servizio RPC (che risulta avviato).

Se tento di Avviare i due servizi manualmente mi viene fuori:
Impossibile avviare il servizio X sul computer Locale.
Errore 1068 avvio del gruppo o del servizio di
dipendenza non riuscito.

Mi sembra una catena di S. Antonio. Spero di uscirne.

giancarlof
09-07-2007, 16.16.28
Sembra una cosa seria prima di tutto vedi se si apre il registro eventi, ci credo poco, potrebbe essere solo quello danneggiato.
Prova a cancellare tutti gli eventi: start, esegui, pannello di controllo,
strumenti di amministrazione, servizi, ok. Doppio click sul servizio
"registro eventi" scegli disabilitato come tipo di avvio.
Riavvia.
Apri esplora risorse e vai in \WINDOWS\system32\config e cancella i 3 file
con estensione .evt
Torna in servizi e rimetti automatico come tipo di avvio per registro
eventi, quindi avvia il servizio.
Ora prova ad aprire il registro eventi.

giancarlof
09-07-2007, 16.26.36
Aggiungo che quella è una modifica che faccio da sempre in Windows XP spero che funzioni anche in questo caso. Se riesci a fare l'operazione poi prima di aprire gli eventi riavvia la macchina perchè prenda la variazione apportata.

Alexander_22
10-07-2007, 11.01.04
Nessuna idea?

giancarlof
10-07-2007, 11.20.49
Nessuna idea?

Hai fatto quanto scritto nel post N° 11 ?

Alexander_22
10-07-2007, 12.26.23
Hai fatto quanto scritto nel post N° 11 ?
Si scusa ma non avevo visto i tuoi post. Comunque ricapitolando:
- il registro eventi, come ci si aspettava, non si apre;
- riesco a disabilitare il servizio;
- non riesco ad eliminare i file .evt che mi dicevi tu perchè non esistono su Vista a quanto pare;

Ovviamente mi fermo qui perchè la procedura mi blocca a questo punto. L'errore che mi da in fase di avvio manuale del servizio è: impossibile trovare il file specificato. Ma come rimpiazzo il file? Il servizio Registro Eventi si avvia con l'svchost. :crying:

giancarlof
10-07-2007, 12.55.44
http://www.p2pforum.it/forum/showthread.php?t=203452

Fai anche questa cosa prima leggi bene il link e vedi se serve:

Prova a correggere i file di sistema in emulazione dos:

esegui digita

SFC /PURGECACHE OK

poi digiti


SFC /SCANNOW OK

dopo aver preventivamente messo il dvd del sistema operativo nel lettore/masterizzatore.

Alexander_22
10-07-2007, 13.33.31
http://www.p2pforum.it/forum/showthread.php?t=203452

Fai anche questa cosa prima leggi bene il link e vedi se serve:

Prova a correggere i file di sistema in emulazione dos:

esegui digita

SFC /PURGECACHE

poi digiti


SFC /SCANNOW

dopo aver preventivamente messo il dvd del sistema operativo nel lettore/masterizzatore.

Niente da fare. Pensi che reinstallando solo il S.O. risolvo? In Vista non c'è una soluzione meno drastica (oltre l'SFC) di rimpiazzare le dll?

giancarlof
10-07-2007, 13.43.54
Dovresti fare un ripristino ad un punto precedente oppure avere un'immagine anch'essa precedente all'inconveniente. Fra l'altro vedo che sugli altri forum non ti rispondono nemmeno.

Alexander_22
10-07-2007, 13.57.03
Dovresti fare un ripristino ad un punto precedente oppure avere un'immagine anch'essa precedente all'inconveniente. Fra l'altro vedo che sugli altri forum non ti rispondono nemmeno.

Infatti... Su questo per lo meno sono riuscito a capire qualcosa in più. Ti ringrazio per l'aiuto... Proverò a reinstallare il S.O. e vi aggiorno.
Grazie ancora.

Alexander_22
13-07-2007, 11.48.19
Ci dev'essere qualcosa che non va alla base di questi problemi. Anche operazioni pianificate e il Defrag non partono. La Deframmentazione non si avvia in nessun modo (tranne da DOS) mentre Utilità Operazioni Pianificate mi dice che il servizio non è avviato.
Il pc è fresco di formattazione e cose strane non ne ho fatte a parte attivare l'account Administrator ed usarlo come predefinito.

Non volevo arrivare ad una nuova formattazione ma mi sa che questo fine settimana lo passerò proprio così.
Ciao.

one70
05-07-2013, 16.43.37
Ciao, rispolvero questo thread per segnalare in che modo ho risolto senza formattare, nel mio caso, su XP sp3.
A me dava errore sia all'apertura delle singole voci dell'eventvwr e sia quando tentavo di avviare il "registro eventi" sotto services.msc, e dopo aver tentato QUALSIASI COSA, disperato, mi sono messo a girovagare per il registro di sistema, e qui mi sono accorto che sotto HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Eventlog
era presente una chiave abbastanza strana: "ObêectName" con valore "LocalSystem".
Insospettito dal nome un po troppo "francese" ho comparato la stessa chiave su un altro pc avente XP. Non c'era!! ma al suo posto c'era invece "ObjectName".
In pratica, ho aggiunto manualmente la chiave con valore stringa "ObjectName" e settato il valore in "LocalSystem", ho riavviato e... finalmente ora rivedo il mio visualizzatore eventi!
Spero possa essere utile a qualcuno.
saluti.

borgata
05-07-2013, 16.46.13
Grazie del feedback ;)

cippico
06-07-2013, 16.00.30
complimenti per l'accanimento e per aver trovato la soluzione nei meandri del registro... :Oh-yea:

non male come esordio su WT...

ciaooo