PDA

Visualizza versione completa : RVM WinXP SP2 Update Pack 2.1.11


Thor
01-07-2007, 09.02.26
<div align="center"><img border="0" src="http://www.eng2ita.net/mkportal/templates/Blue/images/logo.gif" title="RyanVM's WinXP SP2 Update Pack" /><br /><br /><br /><br /><b><font size="4" face="Verdana" color="#527bb5">RyanVM's WinXP SP2 Update Pack 2.1.11</font></b></div>
<br /><br /><br />
<div align="justify"><b>RyanVM's WinXP SP2 Update Pack</b> è una raccolta di aggiornamenti integrabili direttamente sul cd di Windows XP SP2. A differenza di AutoPatcher che esegue gli aggiornamenti su un sistema già installato, questo pack serve a creare un CD di windows XP preSP3 completo, che non contiene però nessun tipo di tweak o miglioramento. Il vantaggio principale rispetto ad AutoPatcher è che se viene installato Windows da un CD che abbia il RVMUP integrato dopo non è necessaria l'esecuzione di AP, perchè i file che si vanno ad aggiornare con le patch sono già aggiornati.<br /><br />Assieme a esso, si possono integrare vari addon riguardanti programmi o componenti del sistema operativo.<br /><br />Disponibili <a href="http://www.eng2ita.net/release/rvm_giu.txt" target="_blank">le novità</a> di RyanVM's WinXP SP2 Update Pack.</div>
<br /><br /><br /><br />
<table cellspacing="2" cellpadding="2" border="0" align="left"><tbody><tr><td><img width="20" height="20" src="http://www.wintricks.it/image/icons/homeicon.gif" /></td><td bgcolor="#527bb5"><font size="1" color="#ffffff"><b>Homepage</b></font></td><td><font size="2"><a href="http://www.eng2ita.net/index.php?pid=6" target="_blank">RyanVM's WinXP SP2 Update Pack</a> by <a href="http://www.ryanvm.net/msfn/" target="_blank">Ryan VanderMeulen</a></font></td></tr><tr><td><img width="20" height="20" src="http://www.wintricks.it/image/icons//winflag.gif" /></td><td bgcolor="#527bb5"><font size="1" color="#ffffff"><b>Sistemi operativi</b></font></td><td><font size="2">Windows XP SP2</font></td></tr><tr><td><img width="20" height="20" src="http://www.wintricks.it/image/icons/progfolder.gif" /></td><td bgcolor="#527bb5"><font size="1" color="#ffffff"><b>Licenza</b></font></td><td><font size="2">Freeware</font></td></tr> <tr><td><img width="20" height="20" src="http://www.wintricks.it/image/icons/filesize.gif" /></td><td bgcolor="#527bb5"><font size="1" color="#ffffff"><b>Download</b></font></td><td><font size="2"><a href="http://www.eng2ita.net/index.php?pid=6">RyanVM's WinXP SP2 Update Pack 2.1.11</a><br /><font size="1" color="#ff6600">pagina di riferimento per tutti i downloads</font></font></td></tr> </tbody></table>
<br /><br /><br /><br /><br /><a href="http://www.wintricks.it/framer.php?url=122488" target="_blank"> </a><br />

rosalinda
01-07-2007, 09.03.58
provo...ottimo, quanto tempo risparmiato

polare
01-07-2007, 13.53.03
Sembra molto interessante, ma o sbaglio qualcosa o c'è qualche probs con le versioni ita.
Ho provato a seguire la guida che c'è qua http://www.eng2ita.net/forum/ryan_integr.php, installato RVM Integrator, scaricato Pack 2.1.11 in italiano, ho seguito la procedura di integrazione (integrato il pack sul cd di xp con sp2), fatto l'iso e provata su virtual machine... appena si avvia windows da una serie di errori su alcune dll e rundll32...
suggerimenti? consigli?

Ciao

Max_ita
01-07-2007, 15.09.26
Ti consiglio di provare anche con nLite per vedere se ci sono differenze.
Assicurati di non aver integrato altro oltre il Ryan o di non aver fatto personalizzazioni varie durante o prima dell'integrazione del ryan.

Nel forum c'è gente molto esperta che sa il fatto suo e che aiuta molto in queste integrazioni. ;)

polare
01-07-2007, 15.11.28
Tra l'atro mi sono registrato sul forum di discussione ieri, non ho fatto intempo nenanche a postare nulla, quindi non mi sembra di aver fatto nulla di male... è mi ritrovo bannato.. con un messaggio che scrive:
"
E'accaduto un errore!
Spiacente Visitatore, sei escluso dall'utilizzo di questo forum!
Ha creato scompiglio nel forum "

Non posso nemmeno chiedere speigazioni, perchè sulla home non c'è nessun indirizzo email..bho.. mi giunge nuovo il fatto che registrarsi a un forum senza postare crei scompiglio... l'unica cosa che potrebbe "motivare" la cosa è che per la registrazione ho usato un indirizzo email che scompare dopo 10min... ma mi sembra eccessivo un ban..no?

vabbe scusate lo sfogo... spero solo di riuscire a usare questo software molto utile

Ciao

esdisu
01-07-2007, 15.11.39
provo...ottimo, quanto tempo risparmiato
Aspetta a dirlo :mm: , non fare la fine di polare in fatto di tempo ... :wall:

Max_ita
01-07-2007, 15.13.22
Tra l'atro mi sono registrato sul forum di discussione ieri, non ho fatto intempo nenanche a postare nulla, quindi non mi sembra di aver fatto nulla di male... è mi ritrovo bannato.. con un messaggio che scrive:
"
E'accaduto un errore!
Spiacente Visitatore, sei escluso dall'utilizzo di questo forum!
Ha creato scompiglio nel forum "

Non posso nemmeno chiedere speigazioni, perchè sulla home non c'è nessun indirizzo email..bho.. mi giunge nuovo il fatto che registrarsi a un forum senza postare crei scompiglio... l'unica cosa che potrebbe "motivare" la cosa è che per la registrazione ho usato un indirizzo email che scompare dopo 10min... ma mi sembra eccessivo un ban..no?

vabbe scusate lo sfogo... spero solo di riuscire a usare questo software molto utile

Ciao

Ti consiglio di non usare email a tempo... ultimamente c'è stato qualcuno che pare abbia creato molti grattacapi su quel forum.... speriamo in bene.

polare
01-07-2007, 15.19.20
Ti consiglio di provare anche con nLite per vedere se ci sono differenze.
Assicurati di non aver integrato altro oltre il Ryan o di non aver fatto personalizzazioni varie durante o prima dell'integrazione del ryan.

Nel forum c'è gente molto esperta che sa il fatto suo e che aiuta molto in queste integrazioni. ;)

Ciao Max_ita
Personalizzazioni o altro non ne ho fatte e non ho integrato nulla di piu'
Ho copiato su hdd il cd di xp con sp2, scaricato l'integrator, dandogli il path su disco della copia di xp, dato il path di Pack 2.1.11 in italiano e poi ho lanciato l'integrazione, alla fine ho fatto l'iso con il programma incluso nell'integrator (mkisofs), che ha impiogato forse 1h per farla, ma comunque funzionante. ho creato una virtual machine e ho fatto boot dall'immagine...l'installazzione tutto liscio, ma quando faccio il primo login mi da questi errori.. ora non so dirti di preciso su quali dll o il messaggio preciso..ora provo a rifare il tutto e vi dico esattamente i messaggi di errore/dll

Grazie
Ciao

Max_ita
01-07-2007, 15.22.34
Ciao Max_ita
Personalizzazioni o altro non ne ho fatte e non ho integrato nulla di piu'
Ho copiato su hdd il cd di xp con sp2, scaricato l'integrator, dandogli il path su disco della copia di xp, dato il path di Pack 2.1.11 in italiano e poi ho lanciato l'integrazione, alla fine ho fatto l'iso con il programma incluso nell'integrator (mkisofs), che ha impiogato forse 1h per farla, ma comunque funzionante. ho creato una virtual machine e ho fatto boot dall'immagine...l'installazzione tutto liscio, ma quando faccio il primo login mi da questi errori.. ora non so dirti di preciso su quali dll o il messaggio preciso..ora provo a rifare il tutto e vi dico esattamente i messaggi di errore/dll

Grazie
Ciao

Fai tutti gli esperimenti del caso e facci sapere. ;)
Che io sappia il Ryan Update Pack non sempre gira bene su virtual machine.... se hai fatto tutto correttamente e provato sia con Nlite che con l'Integrator, potrebbero trattarsi di errori della macchina virtuale.

Conoscere le dll di errore può aiutare a sapere se è la virtual machine oppure no... prova anche con Nlite, creando di nuovo la cartella del cd di xp sp2, così possiamo fare confronti.

polare
01-07-2007, 17.28.21
Ho rifatto il tutto, spero non sia un problema, se posto il log dell'integrazione e mi dilungo dei dettagli

Copio il cd di XP con SP2 su HDD nella dir c:\WXPSP2_IT\ (ovviamnte è il cd senza le 70 e forse + patch che sono uscite fino ad oggi)
Avvio RVM_Integrator_1.4.3 e do i path necessari, senza alcune addon pack e faccio partire l'integrazione (RVMUpdatePack-2_1_[1].1.11-it.7z):

01-07-2007 15¦31¦58
Log Startup @ 15:31:58 On 01-07-2007

15:31:58 - System Running: WIN_XP Service Pack 2
15:31:58 - RVMIntegrator v1.4.3
15:31:58 - C:\RVM_Integrator_1.4.3\RVM_Integrator_1.4.3.exe
15:33:07 - Windows XP Professional - Retail SP2 Found
15:37:36 -
15:37:36 - Source Drive = C:\WXPSP2_IT
15:37:36 - Destination Drive = C:\WXPSP2_IT
15:37:36 - Destination Size = 14071.01953125
15:37:36 - Working Directory = C:\WXPSP2_IT\I386
15:37:36 - Temp Directory = C:\WXPSP2_IT\I386\rvmtemp
15:37:36 -
15:37:36 - Starting Integration
15:37:36 -
15:37:36 - Checking Destination For OS Type.
15:37:36 - Windows XP Professional - Retail SP2 Found
15:37:36 - Clearing any Read Only Attributes.
15:37:38 -
15:37:40 - Extracting RVMUpdatePack-2_1_[1].1.11-it.7z
15:37:40 - MD5 Hash = ac1d11a1a915159802a31bb006eb26f3
15:37:57 -
15:37:57 - Gathering temp files
15:37:58 - Expanding driver.cab
15:38:46 - Expanding SP2.cab
15:38:58 - Copying files for driver.cab repackaging.
15:39:01 - Moving files for driver.cab repackaging.
15:39:01 - Integrating XP Professional Files.
15:39:01 - Compressing Files
15:42:45 - Shifting Stuff Around
15:42:45 -
15:43:11 - Analyzing 1 Entry Files
15:43:11 - Processing RyanVM Update Pack v2.1.11 Build Date: 06/21/2007
15:43:13 - obsolete_files Found in entries.ini
15:43:14 - Processing Sysoc.inf
15:43:14 - Adding Components
15:43:14 - Processing svcpack.inf
15:43:14 - removing obsolete hotfixes
15:43:14 - adding ProductCatalogsToInstall
15:43:14 - Processing dosnet.inf
15:43:14 - Modifying any SP2.cab areas in dosnet.inf
15:43:14 - Editing [Files]
15:43:14 - Editing [Files] - XP Professional Only
15:43:14 - Processing txtsetup.sif
15:43:14 - Editing [Fileflags]
15:43:15 - Editing [WinntDirectories]
15:43:15 - Editing [SourceDisksFiles]
15:43:15 - Editing [SourceDisksFiles] - XP Professional Only
15:43:15 - Modifying any SP2.cab areas in txtsetup.sif
15:43:28 - Entire .ini Processing Completed in 16 Seconds
15:43:28 - Compressing and Moving Edited Files
15:43:28 -
15:43:28 - Processing mmssetup.cab
15:43:28 - Expanding mmssetup.cab
15:43:28 - Processing entries.ini
15:43:28 - Rebuilding mmssetup.cab
15:43:30 - Rebuilding mmssetup.cab Complete.
15:43:31 -
15:43:31 -
15:43:31 - Calculating the amount of files to pack into driver.cab
15:43:43 - Rebuilding driver.cab
15:52:47 - Rebuilding drvindex.inf
15:52:47 - Rebuilding drvindex.inf Complete.
15:52:47 - Moving Files
15:52:48 - Cleaning Up.
15:52:48 - Replacing driver.cab
15:52:51 - Integration is at 100%, Cleaning Up
15:52:52 - Integration Completed.
15:52:52 - Total Integration Time = 916 Seconds
15:52:52 -

- Finita l'integrazione faccio l'iso con il programma incluso nel RVM_Integrator_1.4.3 (ci impiega una cifra e per tutto il tempo usa la cpu al 100%...bug?)

=====================================
15:52:52 -
15:54:10 -
15:54:11 - Creating ISO
15:54:11 - Command Line = C:\WINDOWS\system32\cmd.exe /c C:\DOCUME~1\User\IMPOST~1\Temp\~RvmInt\mkisofs.exe -joliet-long -iso-level 2 -N -d -relaxed-filenames -duplicates-once -D -boot-load-seg 0x7C0 -boot-load-size 4 -o "C:\RVM_Integrator_1.4.3\WXPSP2_IT.iso" -b rvmintegrator.img -hide rvmintegrator.img -hide boot.catalog -J -hide-joliet xpboot.img -hide-joliet boot.catalog -no-emul-boot -volid "WXPSP2_IT" -sysid "Win32" "C:\WXPSP2_IT"
15:54:11 - Using Internal mkisofs 2.01-bootcd.ru (i686-pc-mingw32)
16:07:23 - Size of boot image is 4 sectors -> No emulation
16:38:25 - Total translation table size: 2048
16:38:25 - Total rockridge attributes bytes: 0
16:38:25 - Total directory bytes: 705166
16:38:25 - Path table size(bytes): 2730
16:38:25 - 301880 extents written (589 MB)
16:38:25 - ISO Complete

-Completata l'iso, inzio l'installazione su una virtual machine:
-Prima anomalia, nel corso dell'installazione, come consuetudine, appare la finestra di "opzioni internazionali e della lingua" e qua, diversamente dal solito (il cd è in italiano) mi propone come opzione standard la lingua inglese e non l'italiano, quindi io vado a modificare e metto tutto in italiano...poi l'installazione prosegue normalmente fino alla fine.
-Primo login in windows mi si presentano le seguenti anomalie:
finestra popup con titolo: "rundll32.exe impossibile individuare un componente" impossibile avviare l'applicazione specificata. framedyn.dll non è stato trovato. una nuova installazione dcell'applicazione potrebbe risolvere il problema. (do l'ok)
-Nell'event view registro di sistema c'è un errore origine Setup che dice:
Durante l'installazione si sono verificati errori non gravi.Ulteriori informazioni sono disponibili nel file setuperr.log nella cartella di windows.
Andabdo a vedere questo log c'è una mare di errori
mentre nel registro applicazione ci sono 2 errori con origine VSS e Userenv
-Si apre una altra popup con titolo RUNDLL che dice errore durante il caricamento di srclient.dll. impossibile trovare il modulo specificato.
Questi errori compaionjo a ogni riavvio

Dubbio:
Prima di integrare RVMUpdatePack-2_1_[1].1.11-it.7z che occupa ~48Mb, devo fare prima un integrazione di altro? possibile che questo update di 40Mb ha già inculuso tutte le patch dal SP2 a oggi?

Spero sia utile per potermi far aiutare dai piu' esperti e che alla fine riesca a usare questo software :)

Ora poi appena ho tempo proverò a usare Nlite

Grazie a tutti
Ciao

Max_ita
01-07-2007, 19.05.55
Hai fatto tutto nel modo corretto.
Gli errori srclient/framedyn indicano una integrazione fallita del pack... se il file non è corrotto è meglio che utilizzi nLite partendo da una nuova cartella dei file di installazione di XP SP2 (niente addon o impostazioni personalizzate, mi raccomando).

Per fugare ogni dubbio sull'interezza del file fai una verifica dell'hash md5 e vedi se corrisponde:

MD5 Hash: AC1D11A1A915159802A31BB006EB26F3

Per controllare l'hash md5 del file che hai scaricato usa questa utility e fammi sapere se coincide:

http://www.nullriver.com/index/products/winmd5sum

Se durante la prova con Nlite gli errori sono gli stessi di quelli dell'Integrator, molto probabilmente si tratterà della virtual machine, il Ryan Update Pack è stabile in quanto è stato correttamente integrato da altri su macchine reali... quindi è possibile arrivare a questa conclusione.

La schermata della scelta delle impostazioni internazionali in cui scegliere la nostra lingua è normale, così come gli errori nel setuperr.log... quelli sono presenti anche nel Ryan Inglese e non creano problema, sono solo falsi allarmi.

Dimenticavo, qui c'è scritto come rendere la lingua italiana di default:
http://www.eng2ita.net/forum/index.php?topic=1806.0

rondix
01-07-2007, 20.01.02
Ottima possibilita' con questo programma ma ancora troppi errori, preferisco sempre NLite che mi permette di aggiornare e alleggerire Xp prima di caricarlo. Mi ha dato i migliori risultati la 1.0 Final dopo innumerevoli tentativi con la quale non ho mai avuto problemi d'integrazione con gli Hotfix.

Perusar
02-07-2007, 08.17.43
Ottima possibilita' con questo programma ma ancora troppi errori, preferisco sempre NLite che mi permette di aggiornare e alleggerire Xp prima di caricarlo. Mi ha dato i migliori risultati la 1.0 Final dopo innumerevoli tentativi con la quale non ho mai avuto problemi d'integrazione con gli Hotfix.

(Y) sono d'accordissimo. Provato tante volte, con diverse versioni, mai un errore nella successiva installazione del SO

polare
02-07-2007, 19.17.54
Hai fatto tutto nel modo corretto.
Gli errori srclient/framedyn indicano una integrazione fallita del pack... se il file non è corrotto è meglio che utilizzi nLite partendo da una nuova cartella dei file di installazione di XP SP2 (niente addon o impostazioni personalizzate, mi raccomando).

Per fugare ogni dubbio sull'interezza del file fai una verifica dell'hash md5 e vedi se corrisponde:

MD5 Hash: AC1D11A1A915159802A31BB006EB26F3

Per controllare l'hash md5 del file che hai scaricato usa questa utility e fammi sapere se coincide:

http://www.nullriver.com/index/products/winmd5sum

Se durante la prova con Nlite gli errori sono gli stessi di quelli dell'Integrator, molto probabilmente si tratterà della virtual machine, il Ryan Update Pack è stabile in quanto è stato correttamente integrato da altri su macchine reali... quindi è possibile arrivare a questa conclusione.

La schermata della scelta delle impostazioni internazionali in cui scegliere la nostra lingua è normale, così come gli errori nel setuperr.log... quelli sono presenti anche nel Ryan Inglese e non creano problema, sono solo falsi allarmi.

Dimenticavo, qui c'è scritto come rendere la lingua italiana di default:
http://www.eng2ita.net/forum/index.php?topic=1806.0

Ciao Max_ita
Ho controllato l'MD5 e corrisponde, poi provo con Nlite e vi faccio sapere :)
PEr quanto riguarda il link al forum.. al massimo proverò a riregistrarmi con una mail fissa..sperando non abbiano bannato l'ip

Grazie a tutti

Ciao