PDA

Visualizza versione completa : Easyphp e Webserver Pubblico


gioffry
21-05-2007, 10.18.58
Ciao ragazzi,
come in oggetto, ho un problema.

Ho installato Easyphp, tutto perfettamente funzionante in locale
http://localhost
http://127.0.0.1
Tutto mi funziona

persino il mio ip: http://gxm.no-ip.info

all'esterno, però, non riescono a vedere...in sostanza non riesco a rendere pubblico il mio webserver

il problema non credo sia l'easyphp ... ho configurato anche per bene l'apache modificando Listen *:80

pensavo il problema potesse risiedere nel windows e nel suo firewall (ho messo da poco l'SP2) ma ho provato ad aprire le porte 80 e 8080 ... nulla!

Come risolvo il problema?

Grazie Anticipatamente

Doomboy
21-05-2007, 17.22.04
Tu hai nattato la porta 80 dal tuo router verso il tuo webserver?

gioffry
21-05-2007, 19.43.05
non ho un router, ho un semplice modem hamlet

Doomboy
21-05-2007, 20.58.18
non ho un router, ho un semplice modem hamlet

Ed hai un firewall attivo? Se fai una telnet (da fuori) verso il tuo dns virtuale sulla 80 che succede?

gioffry
22-05-2007, 00.02.17
da fuori? ho provato via ftp ... connette, ma sempre dal mio pc bisognerebbe far provare a qualcunaltro

gioffry
22-05-2007, 09.42.00
ti confermo che telnettando da fuori:

[09:35] <johnny> WinSock 2.0 -- OpenSSL 0.9.8b 04 May 2006
[09:35] <johnny> [R] In connessione a 82.57.98.242 -> IP=82.57.98.242 PORT=80
[09:35] <johnny> ed è finita lì

telnettando da dentro

[09:36] <gioffry> WinSock 2.0 -- OpenSSL 0.9.8b 04 May 2006
[09:36] <gioffry> [R] In connessione a 82.57.98.242 -> IP=82.57.98.242 PORT=80
[09:36] <gioffry> [R] Connesso a 82.57.98.242

Doomboy
22-05-2007, 09.44.45
Ok, ma apache l'hai messo in ascolto su *:80 ?

gioffry
22-05-2007, 09.53.37
Listen *:80

e ho anche disabilitato il firewall di windows xp sp2

sto nel panico disperato

gioffry
22-05-2007, 23.05.01
UP :(