PDA

Visualizza versione completa : Excel


LoryOne
17-05-2007, 10.43.29
buon giorno miei prodi.
Sono nel canneto.
Ho una sitiazione del genere:
colonna A
2%
1%
2%
2%

colonna b
aa
bb
cc aa
dd bb

colonna c
1
2
3
4

dovrei ottenere la somma della colonna c dove la colonna b contiene aa e la colonna a è pari al 2%, cioè devo ottenere 4.
ho provato con matr.somma.prodotto, ma come faccio a fargli capire che la colonna b deve contenere, non essere uguale a aa ?

ps: no macro, se possibile.

Thor
17-05-2007, 11.27.24
Prova con

=MATR.SOMMA.PRODOTTO((A1:A10=2%)*(B1:B10="aa")*(C1:C10))

se no non ho capito bene..

LoryOne
17-05-2007, 11.56.14
Eh no, non funzia perchè non è =aa ma contenere aa

Dav82
17-05-2007, 12.20.30
Mh.. se ti puoi fare una colonna "di servizio", in questa (colonna D) ci metti

=SE(E(A1=0,02;TROVA("aa";B1));"ok";"")

(ok, se non trova il testo viene fuori #VALORE, ma tanto sei nel canneto, fuori non si vede :D)

Poi con un =SOMMA.SE(D1: D4;"ok";C1:C4) trovi quello che ti serve :)


(C'è anche volendo il SOMMA.PIU.SE, ma ha gli stessi problemi delle altre funzioni di sto tipo... la valutazione viene fatta sull'uguaglianza delle celle con un parametro della funzione)

LoryOne
17-05-2007, 12.53.38
[quote]
(ok, se non trova il testo viene fuori #VALORE, ma tanto sei nel canneto, fuori non si vede )
[\quote]

:D :D

E' vero. Grazie ad entrambi

LoryOne
17-05-2007, 15.39.01
Trovato soluzione:

=MATR.SOMMA.PRODOTTO((A1:A4=2%)*(VAL.ERRORE(RICERC A("aa";B1:B4))=FALSO)*(C1:C4))

In pratica il prodotto è inteso come AND logico fra tutte le celle della matrice, riga dopo riga.
In questo caso effettua una somma quando l'AND logico risultante è TRUE.

Faticaccia ragazzi :)

LoryOne
17-05-2007, 15.50.50
Riporto per correttezza di logica di pensiero, la "soluzione" proposta da un collega ingegnere al quale devo 2 caffè. (Y)

{=SOMMA(SE((VAL.ERRORE(RICERCA("aa";B1:B4))=FALSO)*(A1:A4=2%);C1:C4))}
Occhio che è in forma matriciale.

Ho posto la "soluzione" tra doppi apici perchè la modifica di "aa" in "bb", per esempio, non è immediatamente calcolata da Excel, quindi poco pratica.
Il risultato è però identico.

Dav82
17-05-2007, 15.51.41
Bella Lory (Y) :)


Edit: ecco, avevo già aperto Excel per vedere di adattare la tua soluzione al mio tentativo precedente... grazie! (si sa, poi se uno [leggasi: Dav] non ne viene a capo... diventa matto :))