PDA

Visualizza versione completa : problema excel (openoffice 2.0 calc)


pritt
12-04-2007, 18.25.16
Il problema è questo:
ho creato la seguente formula:=SE(B5=Tabella2.A3;Tabella2.B3;SE(B5=Tabel la2.A4;Tabella2.B4))
adesso dalla cella nella quale l'ho creata vorrei copiarla ed incollarla sulle successive della stessa colonna facendo in modo che cambi solo il valore B5 in B6,B7,B8... e così via, mentre gli altri valori restino come sono. Tuttavia quando faccio il copia ed incolla a cambiare in ordine crescente sono tutti i dati cioè B5 diventa B6 ma anche Tabella2.A3 diventa Tabella2.A4, stranamente se faccio invece il taglia ed incolla selezionando l'intera riga la formula cambia così come vorrei quindi da ciò desumo che esiste il modo per poter ottenere quello che desidero e appunto vorrei sapere questo modo qual'è. Grazie :fool:

Dav82
12-04-2007, 18.53.21
Non so come funzioni su OpenOffice, però su Excel il problema si risolverebbe con qualche dollaro, che "fissa" i riferimenti presenti nelle formule, ovvero:

SE(B5=Tabella2.A3;Tabella2.B$3;SE(B5=Tabella2.A$4; Tabella2.B$4))


Mettendo il $ sui riferimenti riga, "tirando" le formule nelle righe sottostanti il valore col dollaro non viene cambiato, mentre quello senza dollaro sì. Stessa cosa per i riferimenti colonna, "tirando" le formule su colonne adiacenti.

Prova, magari anche su OOo funziona così :) (o con un metodo analogo)

Xtefano
13-04-2007, 08.40.22
.......
Prova, magari anche su OOo funziona così :) (o con un metodo analogo)

E' assolutamente identico ;)



Byez

Stefano

pritt
13-04-2007, 09.42.27
Ho provato e funziona sia con excel che con openoffice ma ho notato una differenza: mentre con excel non si possono immettere più di 7 funzioni concatenate per volta, con OOo questa limitazione non c'è quindi la funzione: =SE(B5=Tabella2.A3;Tabella2.B3;SE(B5=Tabel la2.A4;Tabella2.B4)) può diventare: :=SE(B5=Tabella2.A3;Tabella2.B3;SE(B5=Tabel la2.A4;Tabella2.B4;SE(B5=Tabella2.A4;Tabella2.B4)) ) e così via all'infinito con OOo, mentre alla settima funzione con excel bisogna fermarsi. E' una differenza abbastanza importante ed a completo favore di OOo, qualcuno sà spigarmene i motivi???