PDA

Visualizza versione completa : [*buntu] 6.10 - Installare JAVA


gutguy
21-03-2007, 16.28.15
Ciao,
Ho appena installato ubuntu 6.10 e sto impazzendo per installare java (mi server per la sapgui).
Sto seguendo questa guida (http://blog.agileware.net/index.php/archives/2005/09/30/how-to-install-java-on-ubuntu-linux/) ma lanciando il comando fakeroot mi da errore per cui ho cercato di installare questo tool come descritto ma non c' verso.
Qualcuno sa come si fa d installare sta java?

Gergio
21-03-2007, 17.10.02
ho appena fatto anche io l'installazione, ecco come:

1. ti scarichi il file autoestraente (e' il secondo in questa pagina (http://www.java.com/it/download/linux_manual.jsp?locale=it&host=www.java.com:80))
2. scegli la cartella da cui lo installerai (io ho usato, come riporta la documentazione del sito precedente, /usr/java)
3. apri un terminale e acquisisci i diritti di root (sudo -s e poi ti viene richiesta la tua password)
4. dai i permessi di esecuzione al file (chmod a+x jre-1_5_quello_che_hai.bin)
5. lancia l'eseguibile (./jre-1_5_quello_che_hai.bin)
6. ti chiede di leggere una licenza e di confermarla (yes) e poi scompatta il tutto (lo fa da solo)
7. vai nella cartella dove hai i plugin di firefox (cd /usr/lib/firefox/plugins)
8. crea un collegamento simbolico al plugin del jre (ln -s /percorso_che_hai_scelto_prima/jre1.5_la_cartella_che_ha_creato/plugin/i386/ns7
/libjavaplugin_oji.so
9. (ri)avvia firefox

nota: in caso non lo sapessi, linux ti permette di completare i comandi con il tasto TAB, cosi' non devi scrivere tutto a manina ;)

harman
21-03-2007, 17.11.57
Dopo avere attivato i repository multiverse ti troverai il pacchetto Java Sun in Adept, la installi da l senza problemi (e senza guide)
:)

gutguy
22-03-2007, 10.16.33
Dopo avere attivato i repository multiverse ti troverai il pacchetto Java Sun in Adept, la installi da l senza problemi (e senza guide)
:)

Si infatti avevo letto dopo aver postato che bisognava attivare questi r. cosa che ho fatto, ma per installare questo pacchetto cosa devo fare essattamente?

harman
22-03-2007, 11.03.02
Apri Synaptic (prima ho scritto Adept che l'equivalente per kubuntu) e cerchi i pacchetti

sun-java5-bin
sun-java5-jre
sun-java5-plugin

(oppure sun-java6-bin, sun-java6-jre e sun-java6-plugin)

Poi li selezioni per l'installazione

gutguy
23-03-2007, 13.52.37
Allora ci sono riuscito e vi ringrazio.
Ora io devo installare la sapgui (non so se qualcuno sappia cos) per java,
ma ho un errore quando tento di installarlo (co comando java -jar nonedelfile.jar):

sembra causato dalla mancanza della libreria libgtkpeer

Leggendo una guida all'installazione della sapgui si faceva riferimento alla java j2sdk non so se il problema che ho dovuto al fatto che io ho installato la jre (non so la diff. ma comunque ...).
Qualcuno ha un consiglio da darmi?

harman
23-03-2007, 14.34.51
Allora ci sono riuscito e vi ringrazio.
Leggendo una guida all'installazione della sapgui si faceva riferimento alla java j2sdk non so se il problema che ho dovuto al fatto che io ho installato la jre (non so la diff. ma comunque ...).
Qualcuno ha un consiglio da darmi?

Installa quello che ti chiede, nei pacchetti vedo che c' questa j2sdk :)

gutguy
23-03-2007, 16.23.15
Installa quello che ti chiede, nei pacchetti vedo che c' questa j2sdk :)

ok, come devo fare?

harman
23-03-2007, 16.37.18
Semplice: apri Synaptic e cerchi il pacchetto che ti richiesto e lo selezioni per l'installazione