PDA

Visualizza versione completa : [excel] Intervalli


3bien
13-10-2006, 11.46.07
Ciao a tutti ragazzi :)
Ho un problemino con excel: come faccio a confrontare una cella con un intervallo di celle, ad esempio una colonna?
Mi spiego un p meglio: mettiamo che nella cella A1 ci sia il valore "2000", e nella colonna B ci siano un inseme di numeri, ad esempio 150. Come faccio a controllare se il valore in A1 compreso nella colonna B?
Avevo pensato di usare la funzione "SE", inserendo questa formula
=SE(A1=B:B;"esiste";"non esiste") in un'altra cella.
Ma non funziona! :( Cosa sbaglio? :mm:
Grazie a tutti :)
3Bien

Dav82
13-10-2006, 11.53.32
Io passerei per il CONTA.SE (non mi ricordo se esattamente questo il nome, ho sotto mano una versione inglese e qui si chiama COUNTIF, cmq la trovi facilmente) e lo userei come condizione del SE, in questo modo:

=SE(CONTA.SE(B:B;A1)=1;"esiste";"non esiste")

Cio se nell'intervallo B:B c' una (e una sola) volta una cella uguale alla A1, viene selezionato "esiste", altrimenti "non esiste".


Ciao :)