PDA

Visualizza versione completa : Windows update....BITS bloccato


Joseph31
11-10-2006, 01.22.35
Ciao,
dunque, windows update non scarica più niente, ho visto da services che il servizio trasferimento intelligente in background non è avviato, e quando provo ad avviarlo ricevo un messaggio di errore. Nel visualizzatore di eventi il messaggio è questo:
Servizio Servizio trasferimento intelligente in background terminato. Errore specifico del servizio 2147942405 (0x80070005).
Ho cercato sul sito Microsoft ma non ho trovato niente.
Sapete dirmi come posso sbloccarlo?
Che sia un virus o similare?
Grazie.

RNicoletto
11-10-2006, 11.13.56
Messaggio di errore quando visita il sito Web Windows Update o il sito Web Microsoft Update: "0x800A0046" (http://support.microsoft.com/?scid=kb%3Bit%3B910338&x=11&y=11)

Joseph31
11-10-2006, 14.19.08
Ho seguito le istruzioni del link, ma non ho risolto. Nel passaggio 4 quando inserisco il comando: Wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLO CRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRP WPDTLOCRRC;;;PU) sdset Sc
ho un messaggio di errore per il fatto che Wuauserv non è un comando riconosciuto.
Non so se è per questo, cmq il servizio trasferimento ecc..... continua a non avviarsi con lo stesso errore.

gsmet
11-10-2006, 16.35.47
anche perchè il comando è questo:

Sc sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLO CRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRP WPDTLOCRRC;;;PU)

Non solo wuauserv

Joseph31
11-10-2006, 23.55.40
Vabbè, adesso mi da un altro messaggio di errore (parametro non corretto, ho messo i due punti), Comunque per riavviare il BITS che devo fare?

gsmet
12-10-2006, 00.54.31
Segui queste istruzioni

http://www.faqshop.com/misc/bits/event%20id%207024.htm#Top

Joseph31
24-10-2006, 05.08.34
Queste sono state le parti che mi hanno aiutato a risolvere:

........

2 Another possibility is that the state files (or the directory they are in) is not accessible from the Service, for example if the security on these is set such that LocalSystem doesn't have access to open the state files.

You can find the state files in the directory "%ALLUSERSPROFILE%\Application Data\Microsoft\Network\downloader\". The two state files are "qmgr0.dat" and "qmgr1.dat". Note, for example that the Network or downloader directories may exist but not be accessible to LocalSystem account.

.......

The Downloader directory is created by BITS and should have full access for the Administrators group and also full access for SYSTEM (Local System internal account). You should be able to browse to the Network directory and check the properties of the Downloader directory by right-clicking on the folder for Properties; check the "Security" Tab and make sure that both "Administrators" and "SYSTEM" have all of the "Allow" properties selected (except for "Special Permissions"). None of the "Deny" options should be selected.

(^ qui per la verità non ho capito bene come fare, perchè cliccando con il destro, nelle propietà,non c'è niente che assomigli alla scheda "sicurezza", forse perchè ho solo un account di amministratore? Oppure era per un altro S.O. ?...Boh)

Then check the Security Properties for each of the qmgr0.dat and qmgr1.dat files. These should also have full access for both Administrators and SYSTEM just as with the Downloader directory.



Try deleting the "downloader\" directory and "qmgr0.dat" and "qmgr1.dat" files and see if they are recreated. BTW, Don't delete the "network\" directory.

In this case deleting the "downloader\" directory did the trick - the BITS service starts now.
......


Insomma ho risolto legendo queste ultime righe.... cancellando i files.
sono stati rimpiazzati e il servizio e ripartito.

Ok grazie.... Ciao :)