PDA

Visualizza versione completa : copia files e cartelle desktop da un HDD ad un altro.


sultano86
15-09-2006, 21.12.17
Salve, per prb irreversibile su Windows Xp ( il S.O. si caricava regolarmente ma una volta visualizzato il desktop, circa 30 sec, schermata blu e si riavviava), ho provato con la consolle di ripristino di Windows.
Ho provato tramite la consolle di ripristino utilizzando il comando fixmbr ma probabilmente il prb era di natura differente, cosi ho pensato di ripristinare una configrazione antecedente del SO:-> ma nulla
Non mi è stato possibile nemmeno accedere al visualizzatore di eventi di Windows dato che non facevo in tempo a digitare eventvwr.msc che il pc si riavviava.

Pertanto mi è rimasta l'opzione del classico format c: e via. :crying:
ho dapprima formattato la partizione del SO.
Poi mi sono bloccato
ho effettuato la copia di dati su un altro HDD solo che non mi copia dei files e cartelle che erano posizionate sul desktop...... mi da un msg d'errore
impossibile accedere al file. :wall:
Ho provato a riavviare in modalità provvisoria e accedere al pannello protezione della cartella o file cercando di ottenere il pieno controllo della risorsa ( cartella o file), ma le caselle non sono selezionabili.

Vi chiedo a tutto solitamente c'è una risoluzione.
Quindi ? ci vorrebbe un vostro aiuto ragazzi ..
Grazie. :act:

gsmet
15-09-2006, 22.00.06
il file è danneggiato, oppure... peggio criptato... prova a fare un chkdsk /R sul disco

UG0_BOSS
15-09-2006, 22.01.28
Beh... di solito (ma non sempre) in questi casi si può risolvere provando la copia con un altro SO come un dos lanciato dal floppy o con una distro linux... quindi se hai qualcosa di simile magari si può aggirare il problema.

sultano86
15-09-2006, 22.28.03
Ciao, ragazzi non credo il file sia danneggiato in quanto il prb è su tutti ifiles della cartella desktop, mentre gli altri me li ha copiati regolarmente.
Credo proprio che windows associ ai files che sono sul desktop, possibilità di accedervi solo all'utente che gli ha creati, pertanto ora accedendo da un altro pc con altra utenza, il so mi visualizza tale msg d'errore.
Correggetemi se sbaglio. ;)
Pertanto al momento dovrebbe pur esserci una soluzione al prb. :mm:
remember tutto cio che scrivo no è presunzione.
Vi chiedo solo di cercare di capire come poter risolvere la questione. :)

sultano86
15-09-2006, 22.29.16
cmq
il chkdsk /r già fatto e nn ha riscontrato anomalie sull'HDD.

gsmet
15-09-2006, 22.35.10
Allora in una cartella qualsiasi:

Strumenti->Opzioni cartella...->Visualizzazione

Controlla che l'opzione "Visualizza i file NTFS compressi o crittografati in un altro colore" sia abilitata e dimmi... sono per caso crittografati i file sul desktop?

Sorry... intendevo verdi! :D

UG0_BOSS
15-09-2006, 22.37.16
Credo proprio che windows associ ai files che sono sul desktop, possibilità di accedervi solo all'utente che gli ha creati, pertanto ora accedendo da un altro pc con altra utenza, il so mi visualizza tale msg d'errore.

Si infatti l'ho pensato anch'io...

gsmet
15-09-2006, 22.47.56
Mi sovviene un dubbio. Cosa intendi esattamente con:

accedere al pannello protezione della cartella o file cercando di ottenere il pieno controllo della risorsa ( cartella o file), ma le caselle non sono selezionabili.

Spiega bene così vedo se il problema sta qua

sultano86
15-09-2006, 23.34.40
Ho fatto come mi avete detto ma effettivamente ne i files ne le cartelle dell'ex desktop sono verdi. :wall:
Cmq ho riavviato in modalità provvisoria e col dx su una cartella qualsiasi di quelle in questione -> menu protezione -> nella 1° schermata nn mi da la possibilità, in quanto le caselle in basso nn sono selezionabili, di assumere i diritti di accesso in lettura, controllo, etc etc etc. . :wall:
Probabilmente è possibile sempre tramite il pannello protezione settare parametri ..... questo però nn l'ho mai fatto. :S

sultano86
15-09-2006, 23.36.42
ciao ugo,
da DOS avevo provato e ugualmente mi visualizzava "accesso negato". :grrr:

sultano86
15-09-2006, 23.38.44
ragazzi ditemi pure se nn vi è chiaro, cosi magari vi allego la schermata.

gsmet
15-09-2006, 23.40.41
Okey... allora non andare con la prima schermata, vai avanti con il tasto avanzate, apri la pagina proprietario e poi settati proprietario.

Una volta che sei settato proprietario della cartella e del contenuto (ricordati quindi di selezionare la checkbox per sostituirlo anche in tutti gli oggetti contenuti), sempre in avanzate di protezione nella prima pagina, togli eredita, dai rimuovi, aggiungi solo il tuo utente e dagli accesso totale, quindi digli di sostituirlo nei contenitori e dai okey...

a quel punto se non va il problema sta altrove.

sultano86
16-09-2006, 16.50.04
okey al momento sono a lavoro gsmet farò cosi appena rientro.
Ti posto subito dopo.

Variac
16-09-2006, 19.12.14
...m'era successo anche a me ma non ricordo come feci.

sultano86
17-09-2006, 10.52.44
Ciao Viriac ,
potresti fare mente locale e cercare a questo punto di ricordarti come hai risolto il prb? :mm:
Ad ogni modo in pomeriggio ( ora sn a lavoro) farò come mi ha suggerito gsmet. :)

sultano86
18-09-2006, 04.03.04
:inn:
Ciao gsmet,
mission complete !
ho fatto esattamente come mi hai detto.
mi sn impostato come proprietario della cartella e del suo contenuto ricorsivamente.
Da controllo ho aggiunto le autorizzazioni desiderate associate all'account utente specificato.
Ho tolto la spunta su eredita ........ :jump:
Cosi ho avuto l'accesso alla cartella desktop e ai suoi contenuti.
Grazie per l'aiuto. :act:
;)
ah gsmet, togliendo la spunta da eredita...... cosa chiediamo al sistema?
pauliodomar@tele2.it

gsmet
18-09-2006, 04.17.19
Praticamente ti spiego... i permessi di NTFS possono essere assegnati ad un oggetto, il quale automaticamente li assegna UGUALI a tutti gli oggetti (file e cartelle) contenuti.

Se tu ad uno di questi togli EREDITA, automaticamente gli dici che questo oggetto avrà permessi diversi dal contenitore dove si trova e quindi puoi assegnarli a tuo piacimento.

Capisci che se lo fai sulla cartella di Windows o System32 rischi di segare l'os :P...

Cmq spero di essere stato esauriente... e spero fosse questa la tua domanda :P...

Ciao ciao e lieto di essere stato d'aiuto!

sultano86
26-09-2006, 13.33.53
Perfetto gsmet mi hai chiarito l'idea.
Alla prossima.

borgata
26-09-2006, 15.36.44
Dato che accedi alla linguetta "protezione" immagino si parli di XP Pro, con condivisione file semplice disabilitata.
Vai allora su "Avanzate" - > "Proprietario" e vedi se appare un proprietario diverso da quelli noti (cioè una lunga stringa alfanumerica con qualche - in mezzo).
Sostituisci quindi il proprietario con il tuo utente in uso.

EDIT: Oops mi ero perso la seconda pagina del post... già risolto!