PDA

Visualizza versione completa : [*buntu] 6.06.1 - Aethra Starmodem chipset Sagem + GCC4.0


Dr_House
14-08-2006, 18.53.12
Salve, colgo l'occasione per ringraziarvi anticipatamente per gli aiuti che spero saprete darmi per configurare la kubuntu sul mio PC, premetto che ho già abondantemente usato la funzione cerca nel forum senza riscuotere grandi risultati.

Sono un nuovo utente di questa distribuzione ed ho già accumulato varia esperienza in linux e dopo molta insistenza da parte di alcuni amici e compagni di università ho finalmente deciso di scaricare la Kubuntu e provare questa relese.
Come al solito, avendo un modem USB mi aspettavo di avere gli ormai soliti problemi con il driver eagle-usb pertanto mi sono prevenuto in anticipo scaricandoli dal loro sito ufficiale e metterli sulla pennetta USB per preparare subito dopo l'installazione dei driver e degli script del modem.

Tuttosommato ho incontrato qualche piccolo problema di percorso durante la fase di installazione.

Dopo aver decompattato il file .tar ho eseguito questo comando:

sudo ./configure

Parte tutto regolarmente ma indica che gcc, cpp e le rispettive librerie non sono presenti.

Ho quindi utilizzato il sistema di amministrazione pacchetti disponibile all'interno dei strumenti di Kubuntu per individuare se questi pacchetti fossero disponibili per un eventuale installazione.

Noto che gcc4.0 gcc3.5base, gcc4.0base, cpp etc... sono correttamente installati.

Quindi non so come comportarmi, li rivela installati, ma quando cerco di usarli comunica il solito errore che il comando non esiste.


Ho quindi provato la via due controllando tra gli elenchi dei moduli la presenza nel kernel di Eagle USB, cosa che è avvenuta con successo e dai messaggi di sistema è risultato che i moduli sono presenti e funzionano correttamente, a dimostrazione di ciò confermano le lucette del mio modem che vedono accesa solo quella del POWER e non tutte e tre.
Quindi decido di prelevare il firmware e di provare a inserirlo all'interno del pacchetto firmware in lib/firmware/ quindi per sicurezza riavvio, ma niente, il modem non riesce ad essere sincronizzato.

Quindi procedo con l'alternativa 3, seleziono i pacchetti con i driver e utility

eagle-adsl-tools_1.0.4-14_i386.deb

eagle-adsl-data_1.0.4-14_all.deb

Li installo correttamente e provo ad avviare il modem con il comando


sudo adsl.daemon


ma niente, non va...

Provo quindi un'altra strada installando

eagle-usb-modules-source_2.1.1-2_all.deb

e

eagle-usb-utils_2.1.1-2_i386.deb

ma qui dice che ci sono problemi (e me lo aspettavo) con make pertanto il pacchetto non può essere installato.


Adesso che ho provato tutte queste vie, quella che sto ponderando è di provare a reinstallare correttamente gcc e tutte le librerie c necessarie per compilare manualmente i driver e script e procedere come nel punto 1 dal file .tar.

Come posso intervenire? c'è qualcuno che ha già risolto questi problemi? ho cercato ma non trovo cose simili.. grazie.

Dr_House
15-08-2006, 01.36.47
Salve a tutti, vi sto scrivendo dalla nuova Kubuntu.

Sono riuscito finalmente ad installare senza il minimo problema il modem con questi semplici passi che condivido in modo da agevolare chi come me si trova nella medesma situazione:

1)Impostare il CDROM come fonte di installazione

apt-cdrom add

2) Installare i pacchetti per la compilazione dei moduli di Eagle Usb nel seguente modo:

apt-get install build-essential
apt-get install linux-headers-`uname -r`

3) Munirsi delle sorgenti dei driver Eagle-USB disponibili tranquillamente nel sito ufficiale (http://www.eagle-usb.org/).


Grazie a tutti e a presto!