PDA

Visualizza versione completa : [EXCEL] - Differenza tra 2 orari (cavallo mezza notte)


Captain-Hook
29-06-2006, 13.30.13
Come faccio a fare una differenza tra due orari a cavallo di mezza notte? ESEMPIO:
A1: 22.00
A2: 04.00 del giorno dopo

A3: DIFFERENZA?? (dovrebbe darmi 6 ore)

Il problema è che vorrei riuscirci senza mettere anche la data per ogni orario...Qulcuno può aiutarmi? mi servirebbe urgente per lavoro per calcolare le ore effettuate notturne!!

ps.sto impazzendo per la formula, il formato delle celle A1 e A2 è impostato come ora (es 13:30), mentre la cella a3 è impostata come [h].mm
GRAZIE come al solito!

Cricchia
29-06-2006, 13.49.17
inserisci nella cella A3 questa formula:

=SE(A2>=A1;A2-A1;24-(A1-A2))

e formattala come h.mm

dovrebbe funzionare ;)

Captain-Hook
29-06-2006, 16.44.12
ok...FUNZIONA...però non mi funziona la somma delle differenze di orari....diciamo per il resoconto mensile delle ore lavorate. MI da un numero enorme!

Cricchia
29-06-2006, 17.59.59
prova sommando le differenze così:

ad es. se le differenze sono nelle celle a3 e b3
=testo(a3;"h.mm")+testo(b3;"h.mm")

il formato di questa cella (quella che contiene la somma :p) è [h].mm