PDA

Visualizza versione completa : [KERNEL] Su pc preassemblato non funzionano i live cd


UG0_BOSS
05-06-2006, 21.00.28
Ciao a tutti i LinuxTrickers!!!

Volevo chiedervi un piccolo aiutino, perchè dopo aver testato varie distro sul vecchio pc volevo iniziare a utilizzare qualche live cd su quello nuovo, dato che non ho voglia di fare backup, formattazioni e ripristini vari...

Così sono andato in giro per internet a scegliere qualcosina e alla fine ho deciso di scaricare ubuntu e slax.

Dopo aver masterizzato le immagini su cd inserisco i cd nel drive, riavvio, vado nel menu di boot, imposto la priorità maggiore al drive in questione e riprendo col boot.

A questo punto si manifestano errori:

• Con SLAX si riavvia misteriosamente il pc, tornando alla schermata iniziale "compaq" e ricomincia tutto da capo.

• Con UBUNTU appare la schermata del SO con il menu, ma appena do il comando di avviarsi ritorna la schermata "compaq" già citata in precedenza.

• Con DSL sembra funzionare, ma dopo che do "invio" per iniziare si blocca la schermata prima ancora che compaia qualche messaggio.

Cosa può essere?

Ghandalf
05-06-2006, 21.16.35
Puoi postare le specifiche dell'hardware del tuo PC.

Inoltre, potresti mettere a posto il titolo del thread:

http://www.wintricks.it/forum/showthread.php?s=&threadid=96128

UG0_BOSS
05-06-2006, 21.42.30
(Y) eseguo subito

CPU Intel Pentium IV 2.8 GHz
RAM 512 MB ddr
HD 80 GB
SCHEDA VIDEO ATI radeon 9250
6 porte USB, 2 porte FireWire
DVD writer 16x double layer
Monitor LCD Compaq FP7317 17'

P.S. Non sapevo che tag dare al thread, kernel non mi sembra il più appropriato...

Ghandalf
06-06-2006, 12.20.28
Scheda madre?

:)

UG0_BOSS
06-06-2006, 15.06.19
Manufacturer MICRO-STAR INTERNATIONAL CO., LTD
Model Gamila/Giovani/Neon series
Version 030

Chipset Vendor Intel Corporation
Chipset Model 845G/GL/GE Brookdale Host-Hub Interface Bridge (B1-step)
South Bridge 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge
SMBus Intel Corporation 801DB/DBL SMBus Controller (ICH4/ICH4-L B0 step) @0500

CPU Intel Pentium 4
Cpu Socket Socket 478
Processor Upgrade ZIF Socket

Slots di sistema 3 PCI, 1 AGP

OnBoard devices
Video (Enabled) Intel 845G
Ethernet (Enabled) Realtek RTL8101L
Sound (Enabled) AC97 Audio Codec

Memory Summary
Capacity 512 MBytes
Location System board or motherboard
Maximum Capacity 2048 MBytes
Memory Slots 2
Error Correction 8-bit Parity
Error Correction Capabilities None
Name Matrice memoria fisica
Use System memory
Maximum Memory Module Size 1024 MBytes

Warning! Accuracy of DMI data cannot be guaranteed

Semi.genius
06-06-2006, 17.52.14
Fatto test della RAM? le liveCD si basano soprattutto su quella

UG0_BOSS
06-06-2006, 19.13.05
ok domani ci provo... se non sbaglio il test della ram è meglio farlo più tempo possibile, giusto? Quindi mi conviene farlo iniziare la mattina e poi finirlo verso le 3 del pomeriggio?

Scen
07-06-2006, 15.14.44
Fai andare memtest86 per un pò di ore, se non ti segnala errori sei apposto :)

Ti consiglio di utilizzare il LIVECd per antonomasia, ovvero KNOPPIX, forse con quello hai meno problemi!

UG0_BOSS
07-06-2006, 15.21.28
mi sono dimenti cati di fare il test stamattina.. comunque provo con knoppix e se non funge nemmeno quello faccio un controllo con memtest

UG0_BOSS
10-06-2006, 17.47.16
Allora.. dato che mi serve molto il pc in questo periodo non ho ancora provato a fare il test della ram, intanto sto scaricando knoppix...


Intanto ho provato puppy linux, e questo è il risultato:

Compare la schermata di puppy linux, mi chiede con che modalità fare il boot (ho provato con la normale e una adatta ai pc > 2001 ma i risultati sono gli stessi), una volta scelta la modalità il monitor si riempe di messaggi "Unknown interrupt of fault in EIP" seguito da tre serie di numeri, che credo siano indirizzi di memoria.

Questo mi fa proprio pensare che ci sia bisogno di memtest...

UG0_BOSS
11-06-2006, 00.09.20
Aggiorno: KNOPPIX non funge;
Ho avviato memtest alle 18:00 fino a mezzanotte (pochi minuti fa) e non ha trovato errori.

A questo punto inizio a pensare che sia il kernel ad avere problemi col mio pc, dato che tutte le distro si bloccano allo stesso punto, cioè poco dopo l'inizio della fase di boot.

Cosa potrebbe essere?

Ghandalf
11-06-2006, 01.59.28
hai provato a passare al kernel l'opzione noacpi?

Alcune schede MSI hanno problemi di compatibilità con linux, il problema era di qualche tempo fa ed attualmente un paio di MS-63xx continuano ad avere problemi.

UG0_BOSS
11-06-2006, 10.10.11
provo subito

UG0_BOSS
11-06-2006, 10.31.09
:dance: :jump: :jump:

funzionaaaaaa

hai colpito in pieno.. passando l'opzione noacpi funziona tutto correttamente!!! grazie dell'aiuto!