PDA

Visualizza versione completa : Calcolo viaggio con Excel


Zenit
29-01-2006, 14.35.17
Ho foglio per calcolare i tempi di viaggio, così impostato :

A1 Ora Partenza [h]:mm = 10:30
A2 Tempo Viaggio[h]:mm = 20:00
A3 Ora Arrivo [h]:mm = 30:00

Se volessi ottenere in A3 invece del tempo totale (30:00) Ora di arrivo effettiva = 01/06:00, come dovrei impostarlo ?


Grazie :)

Cricchia
29-01-2006, 15.37.25
devi solo cambiare il formato della cella A3:

se metti come formato [h].mm ti restituisce il tempo trascoro, se metti h.mm ti restituisce l'ora da 00 a 23

;)

Cricchia
29-01-2006, 15.50.27
ah... un'altra cosa... se vuoi che ti venga restitituo il valore come 1/06.00 dove il numero prima della barra rappresenta il numero di giorni trascorsi e quelli dopo alla barra rappresentano l'orario esatto di arrivo, puoi scrivere questa formula (formattando la cella come numero o generale):

=SE((A1+A2)>1;INT(A1+A2)&"/"&TESTO((A1+A2);"hh.mm");TESTO((A1+A2);"hh.mm"))

Zenit
29-01-2006, 21.53.44
Come sempre funziona perfettamente :)

E se volessi fare al contrario

A1 = orario di arrivo = 1/10,30 -
A2 = Durata = 26,00 =
A3 = Ora di partenza = ?


E se si volesse mettere una doppia condizione, del tipo se manca A1 o A2 = 0 ?

E se stessi diventando troppo seccante ? :)
(F)


http://www.wintricks.it/foto/firma.gif

Cricchia
29-01-2006, 23.10.56
allora, se vuoi mettere la condizione che se A1 o A2 non contengono valori, nel primo caso usa questa forumla:

=SE(O(A1="";A2="");0;SE(A1+A2>1;INT(A1+A2)&"/"&TESTO((A1+A2);"hh.mm");TESTO((A1+A2);"hh.mm")))

invece, per quanto riguarda la formula che trova l'orario di partenza, dovresti usare questa:

=SE(O(A1="";A2="");0;TESTO(DESTRA(A1;5);"hh.mm")+SINISTRA(A1;TROVA("/";A1;1)-1)-A2)

la cella è formattata come hh.mm

(per l'ultima formula, ho fatto una prova e mi sembra ok.. ma sto fondendo! :p)

Zenit
29-01-2006, 23.59.59
=SE(O(A1="";A2="");0;TESTO(DESTRA(A1;5);"hh.mm")+SINISTRA(A1;TROVA("/";A1;1)-1)-A2) :( non funziona.

Penso si dovrebbe restare su :

=SE(O(A1="";A2="");0;SE(A1+A2>1;INT(A1+A2)&"/"&TESTO((A1+A2);"hh.mm");TESTO((A1+A2);"hh.mm"))) che funziona perfettamente, solo che invece di addizionare, bisognerebbe sotrarre.

Il tipo di procedimento è lo stesso, solo che non accettando risultati negativi, non riesco a convertirli in positivi. :rolleyes:

Riposati, rilassati e quando hai tempo e voglia, pensaci ;)

Grazie sempre di tutto. (F)

Cricchia
30-01-2006, 12.49.23
ricapitolando... la prima formula funziona?!?! per intenderci quella che l'ora di arrivo nel formato gg/hh.mm?
funziona anche con la condizione che se A1 o B1 è vuota ti restituisce 0?!?!?
:confused:

passiamo alla seconda che ti ho scritto, ovvero quella restituisce l'ora di partenza...
a me sembra che funzioni... infatti se tu metti gli stessi dati che mi hai scritto risulta corretto:

Zenit
30-01-2006, 20.42.15
Ecco dovè la malcomprensione.

Io voglio inserire
A1 = 10:30
A2 = 24:00
ed ottenere
A3 = -1/13:00

Zenit
01-02-2006, 11.17.38
Up :rolleyes:




http://www.wintricks.it/foto/firma.gif

Cricchia
01-02-2006, 11.50.03
Originariamente inviato da Zenit
Ecco dovè la malcomprensione.

Io voglio inserire
A1 = 10:30
A2 = 24:00
ed ottenere
A3 = -1/13:00

uff... adesso non ci capisco più niente io! :(

quest'ultima che hai scritto, mi sembra la prima forumla che hai chiesto:

Originariamente inviato da Zenit
Ho foglio per calcolare i tempi di viaggio, così impostato :

A1 Ora Partenza [h]:mm = 10:30
A2 Tempo Viaggio[h]:mm = 20:00
A3 Ora Arrivo [h]:mm = 30:00

Se volessi ottenere in A3 invece del tempo totale (30:00) Ora di arrivo effettiva = 01/06:00, come dovrei impostarlo ?


Grazie :)

giusto? quindi, se l'ora di partenza è 10.30, ci impiego 24 ore, arrivo 1 giorno dopo alle 10.30 e da qui 1/10.30

e la prima formula che ti ho scritto funziona


=SE(O(A1="";A2="");0;SE(A1+A2>1;INT(A1+A2)&"/"&TESTO((A1+A2);"hh.mm");TESTO((A1+A2);"hh.mm")))


poi, successivamente hai chiesto di fare la cosa inversa:

Originariamente inviato da Zenit
Come sempre funziona perfettamente :)

E se volessi fare al contrario

A1 = orario di arrivo = 1/10,30 -
A2 = Durata = 26,00 =
A3 = Ora di partenza = ?


E se si volesse mettere una doppia condizione, del tipo se manca A1 o A2 = 0 ?

E se stessi diventando troppo seccante ? :)
(F)


http://www.wintricks.it/foto/firma.gif

quindi inserendo l'ora di arrivo nel formato 1/10.30 (che sarebbe +1 giorno, ore 10.30), occorre trovare l'orario di partenza.. se il viaggio dura sempre 24 ore, per me fa sempre 10.30 ma di un giorno prima...

e la seconda formula mi pare che funzioni:


=SE(O(A1="";A2="");0;TESTO(DESTRA(A1;5);"hh.mm")+SINISTRA(A1;TROVA("/";A1;1)-1)-A2)


ora, sinceramente non capisco a cosa faccia riferimento quel 13.00 che hai scritto... :confused:

se mi aiuti a capire, probabilmente sto facendo casino io, provo ad aiutarti ;)

Zenit
01-02-2006, 16.40.07
No cara scusami, è che questi giorni mi sto rincoglionendo io ( stupidità senile ):)

Quello che volevo ottenere non è come giustamente tu dici che è sbagliata,
A3 = -1/13:00 ma, A3 = -1/10:30 (valore negativo)


Perdonami (F)

Cricchia
02-02-2006, 21.54.54
pvt ;)

Zenit
06-02-2006, 16.55.23
Ok funziona tutto alla grande.

Per "sdebitarmi" ti allego la foto della mia ultima "piccolina".

Tu che ami i gatti capirai la cosa.

E' una vera rarità, una Maine Conn, di razza purissima, che invece di tigrata, come generalmente la sua razza, è nera

Eccoti, Perla Nera

http://www.hostfiles.org/files/20060206045657_Perla_017b.jpg (http://www.hostfiles.org)





http://www.wintricks.it/foto/firma.gif

Cricchia
06-02-2006, 23.55.26
ma cucciola!!!! (L)

ehm, i Maine Coon li conosco bene.. me ne sono innamorata quando ne ho presa una in braccio.. pesava almeno 10 Kg ed era un batuffolone tutto bianco :eek:

cmq è bellissima, Zenit! :)

e poi devo ammettere, come ti ho già detto, che anche se è stata dura risolvere il problema, ho imparato qualcosa anch'io! ;)