PDA

Visualizza versione completa : [*buntu] Installare FireFox 1.5


Kjow
10-01-2006, 18.21.20
Come? :D

Ho scaricato il file gz dal sito e ho pasticciato un po'... ma non ho ottenuto risultati... anche dal sito non ci ho capito molto :(

Help :p

Se può interessare attraverso Adept ho installato FireFox 1.0.7 (ma non funziona... l'icona di caricamento gira e rigira e poi si chiude). Anche disinstallandolo la 1.5 non sono riuscito a farla partire :(

Eteria
11-01-2006, 01.02.39
Originariamente inviato da Kjow
...
Se può interessare attraverso Adept ho installato FireFox 1.0.7 (ma non funziona... l'icona di caricamento gira e rigira e poi si chiude). Anche disinstallandolo la 1.5 non sono riuscito a farla partire :(

Hai provato a lanciare l'eseguibile dalla console? Che output ti da?

Kjow
11-01-2006, 12.00.00
si avevo provato, con firefox mi diceva che mancavano le librerie libgtk-2.0, ma in realtà erano installate.
Lanciando invece mozilla-firefox (dopo aver creato un profilo e dopo un errore di un file che mancava) partiva la 1.0.7 e cmq solo da riga di comando...

...cmq sia ora il problema non si presenta più: m'è morto l'hd da 20Gb :rolleyes:

Se avete soluzioni per far andare il raid (http://www.wintricks.it/forum/showthread.php?s=&threadid=100416) su linux ve ne sono grato :)

Ghandalf
12-01-2006, 02.15.32
Ma perché non hai utilizzato un pacchetto deb?..:)

Kjow
12-01-2006, 14.14.53
Originariamente inviato da Ghandalf
Ma perché non hai utilizzato un pacchetto deb?..:)

Mi sembra di aver provato, ho fatto tante prove... ma oramai è tardi, l'hd non viene riconosciuto neanche da bios :(
Confido nel raid :D

gionapper
13-01-2006, 09.29.32
Sul sito italiano di ubuntu, vi è un link sulla wiki in inglese dove spiega passo passo come effettuare l'aggiornamento di Firefox 1.5 su sistemi ubuntu/kubuntu. La procedura funziona correttamente anche se vi do un consiglio (valido anche per win), cancellate la cartella chrome dall'installazione 1.07.

Ma perché non hai utilizzato un pacchetto deb?
Ti riferisci a Firefox? Perchè a me non risulta ci sia ancora la versione 1.5 in pacchetto .deb
Se così fosse, ignorate il mio consiglio ed installate il pacchetto! :D

Kjow
13-01-2006, 10.12.06
Originariamente inviato da gionapper
Sul sito italiano di ubuntu, vi è un link sulla wiki in inglese dove spiega passo passo come effettuare l'aggiornamento di Firefox 1.5 su sistemi ubuntu/kubuntu. La procedura funziona correttamente anche se vi do un consiglio (valido anche per win), cancellate la cartella chrome dall'installazione 1.07.


Ti riferisci a Firefox? Perchè a me non risulta ci sia ancora la versione 1.5 in pacchetto .deb
Se così fosse, ignorate il mio consiglio ed installate il pacchetto! :D


si, l'avevo seguita... ma si intruppava da qualche parte...

Kjow
16-01-2006, 12.01.16
Niente... ragazzi urge aiutone :D

Ho seguito pari pari la guida:
https://wiki.ubuntu.com/FirefoxNewVersion

ed è tutto ok, ma quando vado a lanciare ./firefox mi da:


:~$ firefox
/opt/firefox/firefox-bin: error while loading shared libraries: libgtk-x11-2.0.s
o.0: cannot open shared object file: No such file or directory

Se lancio locate libgtk-x11-2.0.so.0 me le trova però... non capisco :(

Help! :)

PS non mi parte più neanche Firefox 1.0.7... unica riga restituira: Segmentation Fault
Cos'è successo? :crying: IMP: questo me lo fa da prima di riprovare con ff 1.5 :mm:

ANDY CAPS
16-01-2006, 15.06.26
guarda dove si trova la libreria probabilmente la cerca in un altra posizione e dovresti rilikarla dove al cerca

esempio
se la libreria è in /usr/local/lib/libgtk-x11-2.0.so.0 e la cerca in /usr/lib dovresti dare il comando

ln -s /usr/local/lib/libgtk-x11-2.0.so.0 /usr/lib/libgtk-x11-2.0.so.0

Kjow
16-01-2006, 15.32.21
Ummm...

se lancio locate libgtk-x11-2.0.so.0 ottengo:

:/opt/firefox$ locate libgtk-x11-2.0.so.0
/usr/lib/libgtk-x11-2.0.so.0.800.6
/usr/lib/libgtk-x11-2.0.so.0


Non so però dove cerca la libreria, ho quindi eseguito:

sudo ln -s /usr/lib/libgtk-x11-2.0.so.0 /opt/firefox

mettendo così il link alla libreria nella dir di firefox... ma lanciando firefox da console:

:/opt/firefox$ firefox
/opt/firefox/firefox-bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory


:(

Kjow
20-01-2006, 13.04.07
:/opt/firefox$ firefox
/opt/firefox/firefox-bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory


uppino :p :(

ANDY CAPS
20-01-2006, 14.41.20
guarda se in /opt/firefox hai anche lib e linkala li dentro semmai

Kjow
20-01-2006, 19.15.05
Originariamente inviato da ANDY CAPS
guarda se in /opt/firefox hai anche lib e linkala li dentro semmai

...:~$ ls /opt/firefox/
browserconfig.properties libnss3.so mozilla-xremote-client
chrome libnssckbi.so plugins
components libplc4.so readme.txt
defaults libplds4.so README.txt
extensions libsmime3.so removed-files
firefox libsoftokn3.chk res
firefox-bin libsoftokn3.so run-mozilla.sh
greprefs libssl3.so searchplugins
icons libxpcom_compat.so updater
libgtk-x11-2.0.so.0 libxpcom_core.so updater.ini
libmozjs.so libxpcom.so xpicleanup
libnspr4.so libxpistub.so


c'è :(

...:~$ firefox
/opt/firefox/firefox-bin: error while loading shared libraries: libgtk-x11-2.0.s
o.0: cannot open shared object file: No such file or directory
...:~$ locate libgtk-x11-2.0.so.0
/usr/lib/libgtk-x11-2.0.so.0.800.6
/usr/lib/libgtk-x11-2.0.so.0
/opt/firefox/libgtk-x11-2.0.so.0

ANDY CAPS
20-01-2006, 21.14.46
quello ce lo hai messo te prima

prova a rimuoverlo
poi prova
ln -s /usr/lib/libgtk-x11-2.0.so.0.800.6 /opt/firefox/libgtk-x11-2.0.so.0

controlla con ls -ls /usr/lib/libgtk-x11-2.0.so.0 se punta a /usr/lib/libgtk-x11-2.0.so.0.800.6 spesso un similink di un similink puo non piacergli

Kjow
20-01-2006, 23.17.22
Ummm ho seguito quello che mi hai detto, ma non è cambiato nulla:

...:~$ ls -ls /usr/lib/libgtk-x11-2.0.so.0
0 lrwxrwxrwx 1 root root 25 2006-01-16 11:46 /usr/lib/libgtk-x11-2.0.so.0 -> li
bgtk-x11-2.0.so.0.800.6
...:~$ firefox
/opt/firefox/firefox-bin: error while loading shared libraries: libgtk-x11-2.0.s
o.0: cannot open shared object file: No such file or directory

:mm: :(

ANDY CAPS
21-01-2006, 22.36.09
:confused: probabilmente non gli piace la versione delle librerie

:p firefox 1.5 è sulla ubuntu dapper
io ho aggiornato la breezy a dapper cambiando il sources.list e va anche bene

:rolleyes: se vuoi puoi cambiare il sources.list ( anche provvisoriamente ) per installare firefox direttamente dai server di ubuntu

basta rinominare provvisoriamente /etc/apt/sources.list e mettere i server della dapper al posto della breezy in un nuovo sources.list
io attualmente ho questi

deb http://it.archive.ubuntu.com/ubuntu dapper main restricted
deb-src http://it.archive.ubuntu.com/ubuntu dapper main restricted
deb http://it.archive.ubuntu.com/ubuntu dapper universe multiverse
deb-src http://it.archive.ubuntu.com/ubuntu dapper universe multiverse

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted

deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe


una volta fatta l'operazione
apt-get install firefox ti installa firefox 1.5

apt-get dist-upgrade ti aggiorna tutto a dapper

l'operazione chiaramente è rischiosetta
non so lo stato dell'upgrade che problemi da attualmente
pero' poi ti trovi tutti gli ultimi software installati

Kjow
21-01-2006, 22.58.46
Originariamente inviato da ANDY CAPS
l'operazione chiaramente è rischiosetta
non so lo stato dell'upgrade che problemi da attualmente
pero' poi ti trovi tutti gli ultimi software installati

Niente... ho provato, ma non mi fa aggiornare. Mi dice di fare prima l'update, lo faccio, ma mi richiede (in loop) di fare l'upgrade...

A questo punto temo di dover aspettare una versione ad hoc per la breezy.

Non riesco neanche a compilarlo firefox 1.5 :(


Grazie comunque :) (B)(B)