PDA

Visualizza versione completa : [MDV] Ho fatto il guaio! Crash KDE [RISOLTO]


Gigi75
03-01-2006, 14.03.56
Ecco lo sapevo.. preso troppa confidenza subito :(

Aggiornato a KDE 3.5 e sembrava tutto ok.
Ho importato i fonts di windows (come root e utente) ed è crashato kde
Ora non si avvia più, ricevo un messaggio di errore di xorg.

Che posso fare? Reinstallare tutto di nuovo? Oppure? :( :(

Gigi75
03-01-2006, 14.26.08
Con explore2fs sono entrato nella partizione di linux.. maaaa non so molto che fare :p

Basterà cancellare i fonts importati? o devo cambiare qualcos'altro?

:confused:

Ghandalf
03-01-2006, 14.29.20
Dovresti dirci quale è l'errore esatto del server x..;)

Gigi75
03-01-2006, 14.39.15
mmmm.. ora riavvio e carta e penna mi ricopio tutto (o per caso rialscia qualche file log da qualche parte? :mm: )

In ogni caso ho una mezza idea di cosa possa essere successo..solo che quando è successo non c'ho dato molto peso.

In pratica quando ho importato i caratteri di windows come root ho visto che nella finestra dei caratteri installati non apparivano, anche se la procedura andava a buon fine.
Provando a reinserirli mi chiedeva se sovrascrive, ma continuavano a non vedersi.
Ora guardando in giro nella partizione non li trovo (dovrebbero essere in usr/share/fonts).
L'errore di xorg (te lo riporterò correttamente), andando a memoria, dice proprio che non trova i fonts.

mmmm..mah!

Gigi75
03-01-2006, 15.24.25
Originariamente inviato da Ghandalf
Dovresti dirci quale è l'errore esatto del server x..;)

Questo è l'errore
Could not init font path element unix/:-1, removing from list!

Fatal server error:
could not open default font 'fixed'

Inoltre ti allego il file di log.

:(

Gigi75
03-01-2006, 15.42.46
Trovato un messaggio di un tizio con il mio stesso problema che dice..

Sono Riuscito a fare ripartire con grande gioia di
nuovo xfree86.
Quella che era andato persa era tutta la sezione
riguardante i font.
Dopo avere rimesso tutti path Xfree è ripartito di
nuovo.
Ora vedo di trovare il resto :)
Saluti

mmmm.. si maaaaaaaaaaa..come? :mm:

Gigi75
03-01-2006, 15.55.36
Allora allora...facciamoci del male :p

Credo che al file /etc/x11/xorg.conf manchi una parte.. ovvero questa:

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc101"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/mouse"
EndSection


Il mio file originale è solo questo


# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "SyncMaster"
HorizSync 30-81
VertRefresh 56-75

# Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI"
BoardName "ATI Radeon (fglrx)"
Driver "ati"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection



Giusto? e se sì come faccio? explore2fs non permette di scrivere! :(

Gigi75
03-01-2006, 18.29.28
mmm.. uso il forum come un blocco appunti (vedi mai che torna utile a qualuno :p)

Ho trovato questo

don't worry...your fonts are intact.
what it means is that either you don't have font.dir,font.alias or you are referencing unexisiting fonts.
so make sure that you have all the listed fonts directories (check /etc/X11/XFreexxx file for font references).
if you have all the directories that are referenced from XFreexxx then make sure that each font-directory contains the font.dir and font.alias files.
if they are missing then use mkfontdir on each font directory.
that should fix your problem


Quando torno a casa provo.. ma il problema è sempre quello..

COME! :confused:

Eteria
03-01-2006, 21.55.05
Scusa la banalità della domanda, ma mi viene spontanea, hai provato a reinstallare gli rpm di xorg compresi i fonts di default della tua distro e a vedere se restartando x parte qualcosa?

Gigi75
04-01-2006, 13.08.11
Originariamente inviato da Eteria
Scusa la banalità della domanda, ma mi viene spontanea, hai provato a reinstallare gli rpm di xorg compresi i fonts di default della tua distro e a vedere se restartando x parte qualcosa?

NO banale affatto.. non dare nulla per scontato quando parli di me e linux :p

Quali sono i pacchetti?.. mmm . devo ancora scoprirlo :p


Cmq ora provo a sostituire il file xorg.conf.
Preparo una copia "corretta" del file da mettere in C:\ e poi copio

Visto che ho studiato :D qualcuno mi conferma che questi sono i comandi che devo dare da console?

su
mount /mnt/win_c
cd /etc/X11
cp /mnt/win_c/xorg.conf /etc/x11/xorg.conf


Va bene? :mm:

Ghandalf
04-01-2006, 13.17.53
Petta una soluzione potrebbe essere quella di fare una copia di backup del file /etc/X11/xorg.conf in /etc/X11/xorg.conf.backup ad esempio.

Dopodiché come root dai:

# xorgconfig

e sugui la procedura, queasto ti creerà nuovamente il file xorg.conf. A questo punto X dovrebbe partire, copi la sezione riguardo i fonts nel file xorg.conf.backup che avevi creato e lo sostituisci al file xorg.conf creato con xorgconfig e riavvii X.

Inoltre dovresti potere avviare comunque il sistema mandriva di configurazione testuale del sistema, credo sia o mcc (mandriva control center)...da puoi rimettere a posto tutto riconfigurando X con i tools mandriva..;)


PS fai sempre una copia del file xorg.conf in futuro, cosi' puoi fare i danni che preferisci e poi basta rimpiazzare il file danneggiato..;)

Gigi75
04-01-2006, 13.52.02
Originariamente inviato da Ghandalf
Petta una soluzione potrebbe essere quella di fare una copia di backup del file /etc/X11/xorg.conf in /etc/X11/xorg.conf.backup ad esempio.



Intendi che devo rinominare /etc/X11/xorg.conf in /etc/X11/xorg.conf.backup?

rename /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Giusto?.. se mi dai l'ok provo subito ;) (D)

Gigi75
04-01-2006, 13.58.48
Altra cosa.
Nel percorso dei fonts che ho trovato in rete si legge:
FontPath"/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"

Mentre io in quella posizione ho solo:
75dpi
encodings
misc
speedo
TTF
Type1

Che faccio? copio cmq o devo modificare? :mm:

Gigi75
04-01-2006, 15.04.46
Indovinate da cosa sto postando ora.. :D :cool: :jump: :01:

Grande Raffaele :)
E' bastata la tua dritta (e il mio avatar da battaglia :D)

Bene, risolto. Si cambia titolo? :)

Grazie (B)(B)(B)